summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rwxr-xr-xbin/svn-revision9
-rw-r--r--debian/changelog15
-rw-r--r--debian/compat1
-rw-r--r--debian/control8
-rwxr-xr-xdebian/rules1
-rw-r--r--revision.h7
7 files changed, 34 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index 9d5f783..17d0306 100644
--- a/.gitignore
+++ b/.gitignore
@@ -37,4 +37,3 @@ config.h
config.sh
install
mkdep
-revision.h
diff --git a/bin/svn-revision b/bin/svn-revision
index ec97f0d..c0b460d 100755
--- a/bin/svn-revision
+++ b/bin/svn-revision
@@ -24,6 +24,12 @@ export LC_ALL
TOP="$1"
FILE="$2"
+BRANCH="$3"
+
+if [ -z "$BRANCH" ]; then
+ BRANCH="master"
+fi
+
if [ "x$FILE" = x ]; then
FILE="&1"
@@ -33,7 +39,7 @@ else
fi
if test -d "$TOP/.git"; then
- revnum=`git log --oneline master | wc -l`
+ revnum=`git log --oneline $BRANCH | wc -l`
else
revnum="$oldrev" # keep as is
fi
@@ -62,4 +68,3 @@ EOF
fi
} > "$FILE"
-
diff --git a/debian/changelog b/debian/changelog
index 58e0078..2fefef5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+mailagent (1:3.1-106-1) unstable; urgency=medium
+
+ * Upstream has moved to git. This is the new upstream HEAD
+ * Indeed, whilst the current version worked fine with Debian 7, changes
+ made to INN2 on Debian 9 break the POST command and cause the messages
+ to be rejected as news articles.
+ * Bug fix: "Mailagent not up-to-date", thanks to Raphael Manfredi
+ (Closes: #919182).
+ * Pass configure flags -D cat=/bin/cat -D zcat=/bin/zcat fixes
+ reproducible build on merged-usr vs non-merged
+ * Bug fix: "reproducible build (usrmerge): embeds path of cat and zcat
+ found via PATH", thanks to Andreas Henriksson (Closes: #915303).
+
+ -- Manoj Srivastava <srivasta@debian.org> Thu, 21 May 2020 00:30:17 -0700
+
mailagent (1:3.1-81-4) unstable; urgency=low
* Commented out a $USER in the man page shell sources that was capturing
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index c5e1297..9a02607 100644
--- a/debian/control
+++ b/debian/control
@@ -1,11 +1,11 @@
Source: mailagent
-VCS-Git: https://anonscm.debian.org/git/users/srivasta/debian/mailagent.git
-VCS-Browser: http://anonscm.debian.org/gitweb/?p=users/srivasta/debian/mailagent.git
+VCS-Git: https://salsa.debian.org/srivasta/mailagent.git
+VCS-Browser: https://salsa.debian.org/srivasta/mailagent
Section: mail
Priority: optional
Maintainer: Manoj Srivastava <srivasta@debian.org>
-Standards-Version: 3.9.6
-Build-Depends: groff-base, debhelper (>= 9.0.0), po-debconf, file,
+Standards-Version: 4.3.0
+Build-Depends: groff-base, debhelper-compat (= 12), po-debconf, file,
gettext, libperl4-corelibs-perl, dpkg-dev (>= 1.16.0),
libfile-fcntllock-perl
diff --git a/debian/rules b/debian/rules
index bb0cec7..c9d1c8d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,6 +33,7 @@ override_dh_auto_configure:
eval "$(dpkg-buildflags --export=sh)" && \
sh ./Configure \
-de \
+ -D cat=/bin/cat -D zcat=/bin/zcat \
-D prefix=$(PREFIX) \
-D orgname=/etc/news/organization \
-D myhostname=localhost \
diff --git a/revision.h b/revision.h
new file mode 100644
index 0000000..b917686
--- /dev/null
+++ b/revision.h
@@ -0,0 +1,7 @@
+/*
+ * THIS FILE IS AUTOMATICALLY GENERATED -- DO NOT EDIT
+ *
+ * Generated by ./bin/svn-revision.
+ */
+
+#define REVISION 106