summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2020-05-20 17:09:38 -0700
committerManoj Srivastava <srivasta@debian.org>2020-05-20 17:42:53 -0700
commit522734144b7eeda6bbe8a499d8957661072a9d9e (patch)
treeac411d2f15588d4ce021526f9364d4e6f4b48815
parent2973170ddd6f597f095cf6368beed06be76da589 (diff)
feat(new): New upstream versiondebian/4.3-1archive/debian/4.3-1
This is a new upstream minor version of Make. There are a few backward incompatible changes. Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac2
-rw-r--r--debian/NEWS.Debian36
-rw-r--r--debian/changelog19
-rw-r--r--debian/compat1
-rw-r--r--debian/control6
-rw-r--r--debian/make-guile.links2
-rw-r--r--debian/make.links2
-rw-r--r--make.14
-rw-r--r--src/main.c9
-rw-r--r--tests/scripts/targets/POSIX2
11 files changed, 70 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 80a2ff39..cc30c4a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,7 @@ SUBDIRS = lib po
bin_PROGRAMS = make
include_HEADERS = src/gnumake.h
-man_MANS = doc/make.1
+man_MANS = make.1
make_SRCS = src/ar.c src/arscan.c src/commands.c src/commands.h \
src/debug.h src/default.c src/dep.h src/dir.c src/expand.c \
diff --git a/configure.ac b/configure.ac
index bff36582..a1d41640 100644
--- a/configure.ac
+++ b/configure.ac
@@ -521,7 +521,7 @@ AS_IF([test "x$make_cv_posix_spawn" = xno && test "x$user_posix_spawn" = xyes],
])
# Specify what files are to be created.
-AC_CONFIG_FILES([Makefile build.cfg lib/Makefile po/Makefile.in Makefile \
+AC_CONFIG_FILES([Makefile build.cfg lib/Makefile po/Makefile.in \
tests/config-flags.pm])
# We don't need this: the standard automake output suffices for POSIX systems.
#mk/Posix.mk
diff --git a/debian/NEWS.Debian b/debian/NEWS.Debian
index 08f01cca..dbc45ac8 100644
--- a/debian/NEWS.Debian
+++ b/debian/NEWS.Debian
@@ -1,3 +1,39 @@
+make-dfsg (4.3-1) unstable; urgency=medium
+
+ * WARNING: Backward-incompatibility!
+ Number signs (#) appearing inside a macro reference or function invocation
+ no longer introduce comments and should not be escaped with backslashes:
+ thus a call such as:
+ foo := $(shell echo '#')
+ is legal. Previously the number sign needed to be escaped, for example:
+ foo := $(shell echo '\#')
+ Now this latter will resolve to "\#". If you want to write makefiles
+ portable to both versions, assign the number sign to a variable:
+ H := \#
+ foo := $(shell echo '$H')
+ This was claimed to be fixed in 3.81, but wasn't, for some reason.
+ To detect this change search for 'nocomment' in the .FEATURES variable.
+ * WARNING: Backward-incompatibility!
+ Previously appending using '+=' to an empty variable would result in a value
+ starting with a space. Now the initial space is only added if the variable
+ already contains some value. Similarly, appending an empty string does not
+ add a trailing space.
+ * NOTE: Deprecated behavior.
+ Contrary to the documentation, suffix rules with prerequisites are being
+ treated BOTH as simple targets AND as pattern rules. Further, the
+ prerequisites are ignored by the pattern rules. POSIX specifies that in
+ order to be a suffix rule there can be no prerequisites defined. In this
+ release if POSIX mode is enabled then rules with prerequisites cannot be
+ suffix rules. If POSIX mode is not enabled then the previous behavior is
+ preserved (a pattern rule with no extra prerequisites is created) AND a
+ warning about this behavior is generated:
+ warning: ignoring prerequisites on suffix rule definition
+ The POSIX behavior will be adopted as the only behavior in a future release
+ of GNU make so please resolve any warnings.
+
+
+ -- Manoj Srivastava <srivasta@debian.org> Wed, 20 May 2020 13:56:50 -0700
+
make-dfsg (4.1-2) unstable; urgency=low
WARNING: Backward-incompatibility!
diff --git a/debian/changelog b/debian/changelog
index 19f7e896..c24286bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+make-dfsg (4.3-1) unstable; urgency=medium
+
+ * New upstream version (Closes: #951038).
+ * Bug fix: "man page/info doc enhancement", thanks to Michael Stone
+ (Closes: #912291).
+ * Bug fix: "[PATCH] make-dfsg: Please add support for a
+ &quot;noguile&quot; build-profile.", thanks to Karsten Merker
+ (Closes: #892566). The "noguile" profile results in dropping the
+ build-dependency on guile-2.0-dev and disabling the creation of the
+ "make-guile" binary package. This eases (cross-)building the make
+ package when bootstrapping a new architecture.
+ * Bug fix: "please provide /usr/bin/gmake", thanks to Helmut Grohne
+ (Closes: #898101).
+ * Bug fix: "&#39;make -Orecurse&#39; does not work as expected", thanks
+ to Michael Olbrich (Closes: #909009).Reverted back to upstream
+ version.
+
+ -- Manoj Srivastava <srivasta@debian.org> Wed, 20 May 2020 17:07:47 -0700
+
make-dfsg (4.2.1-2) unstable; urgency=medium
* Update to acknowledge NMUs by Rob Browning and Ben Hutchings.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec635144..00000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 3588b464..b0ab1814 100644
--- a/debian/control
+++ b/debian/control
@@ -4,11 +4,11 @@ VCS-Browser: https://salsa.debian.org/srivasta/make-dfsg
Section: devel
Priority: optional
Maintainer: Manoj Srivastava <srivasta@debian.org>
-Standards-Version: 4.1.3
+Standards-Version: 4.3.0
Homepage: https://www.gnu.org/software/make/
-Build-Depends: gettext, po-debconf, debhelper (>= 9.0.0), dh-autoreconf,
+Build-Depends: gettext, po-debconf, debhelper-compat (=12), dh-autoreconf,
autoconf, automake | automaken, autopoint, file, pkg-config,
- guile-3.0-dev, procps, libbsd-resource-perl <!nocheck>
+ guile-3.0-dev <!noguile>, procps, libbsd-resource-perl <!nocheck>
Package: make
Suggests: make-doc
diff --git a/debian/make-guile.links b/debian/make-guile.links
new file mode 100644
index 00000000..96f913e7
--- /dev/null
+++ b/debian/make-guile.links
@@ -0,0 +1,2 @@
+make usr/bin/gmake
+make.1.gz usr/share/man/man1/gmake.1.gz
diff --git a/debian/make.links b/debian/make.links
new file mode 100644
index 00000000..96f913e7
--- /dev/null
+++ b/debian/make.links
@@ -0,0 +1,2 @@
+make usr/bin/gmake
+make.1.gz usr/share/man/man1/gmake.1.gz
diff --git a/make.1 b/make.1
index ad0d7aa6..d4b5fbab 100644
--- a/make.1
+++ b/make.1
@@ -371,7 +371,9 @@ programs are properly installed at your site, the command
.IP
.B info make
.PP
-should give you access to the complete manual.
+should give you access to the complete manual. Additionally, the
+manual is also available online at
+.IR https://www.gnu.org/software/make/manual/html_node/index.html
.SH "PARALLEL MAKE AND THE JOBSERVER"
Using the
.I -j
diff --git a/src/main.c b/src/main.c
index 04bc2a15..78a27d71 100644
--- a/src/main.c
+++ b/src/main.c
@@ -785,15 +785,10 @@ decode_output_sync_flags (void)
output_sync = OUTPUT_SYNC_NONE;
else if (streq (output_sync_option, "line"))
output_sync = OUTPUT_SYNC_LINE;
- /*
- * benh: -Otarget and -Orecurse can currently cause make to hang
- * (#890309). For now, do the best we can and treat them like
- * -Oline.
- */
else if (streq (output_sync_option, "target"))
- output_sync = OUTPUT_SYNC_LINE;
+ output_sync = OUTPUT_SYNC_TARGET;
else if (streq (output_sync_option, "recurse"))
- output_sync = OUTPUT_SYNC_LINE;
+ output_sync = OUTPUT_SYNC_RECURSE;
else
OS (fatal, NILF,
_("unknown output-sync type '%s'"), output_sync_option);
diff --git a/tests/scripts/targets/POSIX b/tests/scripts/targets/POSIX
index c44cc500..ca9fba94 100644
--- a/tests/scripts/targets/POSIX
+++ b/tests/scripts/targets/POSIX
@@ -30,7 +30,7 @@ all: ; \@$script
'', $out);
# Test the default value of various POSIX-specific variables
-my %POSIX = (AR => 'ar', ARFLAGS => '-rv',
+my %POSIX = (AR => 'ar', ARFLAGS => '-rvU',
YACC => 'yacc', YFLAGS => '',
LEX => 'lex', LFLAGS => '',
LDFLAGS => '',