summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>2011-08-19 17:27:47 +0900
committerKen'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>2011-08-19 17:27:47 +0900
commit2f19359ed119c8c8a4472db28ad614a55bc01963 (patch)
treeadf245976177e1f46e6bdefeeb5006777c2018a2
parent377ba81f8995bda62b9e06150153cbf7c510880e (diff)
[PATCH] Cleanup: Move architecture dependant files to "arch" directory.
There were many source files in root directory and that was little complex. Hence this patch moves architecture dependant files to "arch" directory. Signed-off-by: Ken'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp> ---
-rw-r--r--Makefile4
-rw-r--r--arch/arm.c (renamed from arm.c)4
-rw-r--r--arch/ia64.c (renamed from ia64.c)4
-rw-r--r--arch/ppc64.c (renamed from ppc64.c)4
-rw-r--r--arch/s390x.c (renamed from s390x.c)4
-rw-r--r--arch/x86.c (renamed from x86.c)4
-rw-r--r--arch/x86_64.c (renamed from x86_64.c)4
7 files changed, 14 insertions, 14 deletions
diff --git a/Makefile b/Makefile
index dd90ec7..7c9c2ee 100644
--- a/Makefile
+++ b/Makefile
@@ -26,8 +26,8 @@ endif
SRC = makedumpfile.c makedumpfile.h diskdump_mod.h
SRC_PART = print_info.c
OBJ_PART = print_info.o
-SRC_ARCH = arm.c x86.c x86_64.c ia64.c ppc64.c s390x.c
-OBJ_ARCH = arm.o x86.o x86_64.o ia64.o ppc64.o s390x.o
+SRC_ARCH = arch/arm.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c
+OBJ_ARCH = arch/arm.o arch/x86.o arch/x86_64.o arch/ia64.o arch/ppc64.o arch/s390x.o
all: makedumpfile
diff --git a/arm.c b/arch/arm.c
index 1e82d03..b65c2a0 100644
--- a/arm.c
+++ b/arch/arm.c
@@ -16,8 +16,8 @@
*/
#ifdef __arm__
-#include "print_info.h"
-#include "makedumpfile.h"
+#include "../print_info.h"
+#include "../makedumpfile.h"
#define PMD_TYPE_MASK 3
#define PMD_TYPE_SECT 2
diff --git a/ia64.c b/arch/ia64.c
index 031ebf8..79faa7a 100644
--- a/ia64.c
+++ b/arch/ia64.c
@@ -15,8 +15,8 @@
*/
#ifdef __ia64__
-#include "print_info.h"
-#include "makedumpfile.h"
+#include "../print_info.h"
+#include "../makedumpfile.h"
/*
diff --git a/ppc64.c b/arch/ppc64.c
index 7ad685e..f8fd8d2 100644
--- a/ppc64.c
+++ b/arch/ppc64.c
@@ -20,8 +20,8 @@
#ifdef __powerpc__
-#include "print_info.h"
-#include "makedumpfile.h"
+#include "../print_info.h"
+#include "../makedumpfile.h"
int
get_machdep_info_ppc64(void)
diff --git a/s390x.c b/arch/s390x.c
index 8e01264..9dd613f 100644
--- a/s390x.c
+++ b/arch/s390x.c
@@ -20,8 +20,8 @@
#ifdef __s390x__
-#include "print_info.h"
-#include "makedumpfile.h"
+#include "../print_info.h"
+#include "../makedumpfile.h"
#define TABLE_SIZE 4096
diff --git a/x86.c b/arch/x86.c
index e76abee..f0cd172 100644
--- a/x86.c
+++ b/arch/x86.c
@@ -15,8 +15,8 @@
*/
#ifdef __x86__
-#include "print_info.h"
-#include "makedumpfile.h"
+#include "../print_info.h"
+#include "../makedumpfile.h"
int
get_machdep_info_x86(void)
diff --git a/x86_64.c b/arch/x86_64.c
index a3d3bd7..5e33ab2 100644
--- a/x86_64.c
+++ b/arch/x86_64.c
@@ -15,8 +15,8 @@
*/
#ifdef __x86_64__
-#include "print_info.h"
-#include "makedumpfile.h"
+#include "../print_info.h"
+#include "../makedumpfile.h"
int
is_vmalloc_addr(ulong vaddr)