summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThadeu Lima de Souza Cascardo <cascardo@canonical.com>2019-05-17 12:14:02 -0300
committerThadeu Lima de Souza Cascardo <cascardo@debian.org>2020-03-02 04:48:05 -0300
commit5a8e491d1a9dcdc9e9ecc9980ea2f5f7d0b62b85 (patch)
treeef5e4392feed4331644ba19b9e52ae91c8757656
parent1369ee51cd4b95aa79103c455cbbbeef2b9e26b8 (diff)
Use maxcpus instead of nr_cpus on ppc64el.
On a kdump kernel, nr_cpus is broken, and it will take some time to be properly fixed. In the meantime, we can just use maxcpus. In the worst case, we will get an OOM and reboot instead of panicing too early during boot. Signed-off-by: Thadeu Lima de Souza Cascardo <cascardo@canonical.com>
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 333ccdc..02c0657 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,13 +7,13 @@ else
SUBSTVARS = -Vdist:Depends="kexec-tools"
endif
-KDUMP_CMDLINE_APPEND = nr_cpus=1 systemd.unit=kdump-tools-dump.service
+KDUMP_CMDLINE_APPEND = systemd.unit=kdump-tools-dump.service
ifeq ($(DEB_HOST_ARCH),arm64)
- # pass
+ KDUMP_CMDLINE_APPEND += nr_cpus=1
else ifeq ($(DEB_HOST_ARCH),ppc64el)
- KDUMP_CMDLINE_APPEND += irqpoll noirqdistrib nousb
+ KDUMP_CMDLINE_APPEND += maxcpus=1 irqpoll noirqdistrib nousb
else
- KDUMP_CMDLINE_APPEND += irqpoll nousb ata_piix.prefer_ms_hyperv=0
+ KDUMP_CMDLINE_APPEND += nr_cpus=1 irqpoll nousb ata_piix.prefer_ms_hyperv=0
endif
%: