summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThadeu Lima de Souza Cascardo <cascardo@canonical.com>2019-05-17 12:14:02 -0300
committerThadeu Lima de Souza Cascardo <cascardo@debian.org>2019-07-20 09:13:43 -0300
commit9a70c51dd8251c858137d7f868a3096902bd2298 (patch)
treea77f74759983a7e2c72347f3f56d03a94f3b970f
parent5b27adf188ebd678cf71906f77558593210aef2b (diff)
Use maxcpus instead of nr_cpus on ppc64el.
On a kdump kernel, nr_cpus is broken, and it will take some time to be properly fixed. In the meantime, we can just use maxcpus. In the worst case, we will get an OOM and reboot instead of panicing too early during boot. Signed-off-by: Thadeu Lima de Souza Cascardo <cascardo@canonical.com>
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 333ccdc..02c0657 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,13 +7,13 @@ else
SUBSTVARS = -Vdist:Depends="kexec-tools"
endif
-KDUMP_CMDLINE_APPEND = nr_cpus=1 systemd.unit=kdump-tools-dump.service
+KDUMP_CMDLINE_APPEND = systemd.unit=kdump-tools-dump.service
ifeq ($(DEB_HOST_ARCH),arm64)
- # pass
+ KDUMP_CMDLINE_APPEND += nr_cpus=1
else ifeq ($(DEB_HOST_ARCH),ppc64el)
- KDUMP_CMDLINE_APPEND += irqpoll noirqdistrib nousb
+ KDUMP_CMDLINE_APPEND += maxcpus=1 irqpoll noirqdistrib nousb
else
- KDUMP_CMDLINE_APPEND += irqpoll nousb ata_piix.prefer_ms_hyperv=0
+ KDUMP_CMDLINE_APPEND += nr_cpus=1 irqpoll nousb ata_piix.prefer_ms_hyperv=0
endif
%: