summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorken1_ohmichi <ken1_ohmichi>2008-09-04 09:14:00 +0000
committerken1_ohmichi <ken1_ohmichi>2008-09-04 09:14:00 +0000
commit09364bcc2c7d708ab26fc152705974e01258bb7f (patch)
treef97ee17bff248dc45cbcb42b9fc041fc00b2e439 /Makefile
parent764a449b8bc8e7ddcf08f48fc04134963faa6408 (diff)
[v1.2.9-11] Add makedumpfile's spec file.
This patch adds the spec file, and user can create the rpm file by rpmbuild command. Signed-off-by: Ken'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2848f68..32c16f1 100644
--- a/Makefile
+++ b/Makefile
@@ -31,13 +31,13 @@ $(OBJ_ARCH): $(SRC_ARCH)
makedumpfile: $(SRC) $(OBJ_ARCH)
$(CC) $(CFLAGS) $(OBJ_ARCH) -o $@ $< -static -ldw -lelf -lz
+ zip ./makedumpfile.8.gz ./makedumpfile.8
clean:
rm -f $(OBJ) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz
install:
- zip ./makedumpfile.8.gz ./makedumpfile.8
- cp ./makedumpfile /bin
- cp ./makedumpfile-R.pl /bin
- cp ./makedumpfile.8.gz /usr/share/man/man8
+ cp makedumpfile ${DESTDIR}/bin
+ cp makedumpfile-R.pl ${DESTDIR}/bin
+ cp makedumpfile.8.gz ${DESTDIR}/usr/share/man/man8