summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPratyush Anand <panand@redhat.com>2015-05-16 03:30:57 +0900
committerAtsushi Kumagai <ats-kumagai@wm.jp.nec.com>2015-05-19 10:17:19 +0900
commit94d47d186f3aef93c9e7b14e4ff162e248caaeee (patch)
treed18b2aa5085041804e3eadb096d31a0423497111 /Makefile
parentd64cf7fcf86dd36ae570c0dcb8a3d4a53ece32ad (diff)
[PATCH] Support ARM64.
Patch adds support for ARM64 in makedumpfile. It takes care of vmalloc, vmemmap, module and directly map kernel memory region's translation. Currently we only support 2 leverl 64K pages and VA_BITS as 42. Support to find these machine specific parameters dynamically and then to act accordingly can be added latter. Signed-off-by: Pratyush Anand <panand@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2d2b1b7..fc21a3f 100644
--- a/Makefile
+++ b/Makefile
@@ -49,6 +49,7 @@ SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info
SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c
OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
SRC_ARCH = arch/arm.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c arch/ppc.c
+SRC_ARCH = arch/arm.c arch/arm64.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c arch/ppc.c
OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
LIBS = -ldw -lbz2 -lebl -ldl -lelf -lz