summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorWANG Chao <chaowang@redhat.com>2014-06-10 14:11:27 +0900
committerAtsushi Kumagai <kumagai-atsushi@mxc.nes.nec.co.jp>2014-06-10 16:48:19 +0900
commit45fc42c5c980e2d5b755ed24a6983f44798d958e (patch)
tree7882a0241697e9ae351f8eb0e27747034a91c5a6 /Makefile
parent22a614a0d891dbab0e7901f8dbf387a882c1d5cf (diff)
[PATCH] Fix Makefile for eppic_makedumpfile.so build.
When libeppic isn't installed on a standard location, building eppic_makedumpfile.so with -leppic directly doesn't work. Add LDFLAGS to build arguments, so that one can pass LDFLAGS="-Ldir -Idir" to tell where to search for libeppic library and its header files. For example, if eppic source is installed on the same directory level with makedumpfile as the following: makedumpfile |--- arch +--- eeppic_scripts eppic |--- applications +--- libeppic After compiling libeppic, one can use the following command to build eppic_makedumpfile.so: make LDFLAGS="-I../eppic/libeppic -L../eppic/libeppic" eppic_makedumpfile.so Signed-off-by: WANG Chao <chaowang@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d87638b..0cc07ef 100644
--- a/Makefile
+++ b/Makefile
@@ -87,7 +87,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
eppic_makedumpfile.so: extension_eppic.c
- $(CC) $(CFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo
clean:
rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz