summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorLouis Bouchard <louis.bouchard@ubuntu.com>2014-04-29 16:05:00 +0200
committerLouis Bouchard <louis.bouchard@ubuntu.com>2014-04-29 16:05:00 +0200
commit339e3e26882aa3576f77a7d0c3bee6fdf68ca056 (patch)
treeaa79d4e687d5fb0a5803281e5eda8d9fb00add53 /debian/patches
parentf7fb8b96d9d7be9281570de894538eb795de12d8 (diff)
Fix quilt patches according to new upstream source
Signed-off-by: Louis Bouchard <louis.bouchard@ubuntu.com>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Remove-libebl-linkage.patch10
-rw-r--r--debian/patches/0002-adapt-makefile-to-debian.patch25
2 files changed, 18 insertions, 17 deletions
diff --git a/debian/patches/0001-Remove-libebl-linkage.patch b/debian/patches/0001-Remove-libebl-linkage.patch
index cc045ff..cc45283 100644
--- a/debian/patches/0001-Remove-libebl-linkage.patch
+++ b/debian/patches/0001-Remove-libebl-linkage.patch
@@ -3,11 +3,13 @@ Description: Remove libebl from link options
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
---- a/Makefile
-+++ b/Makefile
-@@ -45,7 +45,7 @@
+Index: makedumpfile-1.5.6/Makefile
+===================================================================
+--- makedumpfile-1.5.6.orig/Makefile 2014-04-25 11:19:24.465438172 +0200
++++ makedumpfile-1.5.6/Makefile 2014-04-25 11:19:24.465438172 +0200
+@@ -51,7 +51,7 @@
SRC_ARCH = arch/arm.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c arch/ppc.c
- OBJ_ARCH = arch/arm.o arch/x86.o arch/x86_64.o arch/ia64.o arch/ppc64.o arch/s390x.o arch/ppc.o
+ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
-LIBS = -ldw -lbz2 -lebl -ldl -lelf -lz
+LIBS = -ldw -lbz2 -ldl -lelf -lz
diff --git a/debian/patches/0002-adapt-makefile-to-debian.patch b/debian/patches/0002-adapt-makefile-to-debian.patch
index 434957d..2b9459b 100644
--- a/debian/patches/0002-adapt-makefile-to-debian.patch
+++ b/debian/patches/0002-adapt-makefile-to-debian.patch
@@ -1,20 +1,17 @@
-Description: Adapt Makefile to debian standards
----
- Makefile | 18 +++++-------------
- 1 file changed, 5 insertions(+), 13 deletions(-)
-
---- a/Makefile
-+++ b/Makefile
-@@ -70,24 +70,16 @@
+Index: makedumpfile-1.5.6/Makefile
+===================================================================
+--- makedumpfile-1.5.6.orig/Makefile 2014-04-25 11:24:21.000000000 +0200
++++ makedumpfile-1.5.6/Makefile 2014-04-25 11:31:06.845448020 +0200
+@@ -77,26 +77,18 @@
- makedumpfile: $(SRC) $(OBJ_PART) $(OBJ_ARCH)
+ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
$(CC) $(CFLAGS) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS)
- echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
-- grep -v "^.TH MAKEDUMPFILE 8" makedumpfile.8 >> temp.8
+- grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
- mv temp.8 makedumpfile.8
- gzip -c ./makedumpfile.8 > ./makedumpfile.8.gz
- echo .TH MAKEDUMPFILE.CONF 5 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.5
-- grep -v "^.TH MAKEDUMPFILE.CONF 5" makedumpfile.conf.5 >> temp.5
+- grep -v "^.TH MAKEDUMPFILE.CONF 5" $(VPATH)makedumpfile.conf.5 >> temp.5
- mv temp.5 makedumpfile.conf.5
- gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
@@ -27,11 +24,13 @@ Description: Adapt Makefile to debian standards
install:
- install -m 755 -d ${DESTDIR}/usr/sbin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
-- install -m 755 -t ${DESTDIR}/usr/sbin makedumpfile makedumpfile-R.pl
+- install -m 755 -t ${DESTDIR}/usr/sbin makedumpfile $(VPATH)makedumpfile-R.pl
- install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8.gz
- install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5.gz
+ install -m 755 -d ${DESTDIR}/usr/bin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
+ install -m 755 -t ${DESTDIR}/usr/bin makedumpfile makedumpfile-R.pl
+ install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8
+ install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5
- install -m 644 -D makedumpfile.conf ${DESTDIR}/etc/makedumpfile.conf.sample
+ install -m 644 -D $(VPATH)makedumpfile.conf ${DESTDIR}/etc/makedumpfile.conf.sample
+ mkdir -p ${DESTDIR}/usr/share/makedumpfile-${VERSION}/eppic_scripts
+ install -m 644 -t ${DESTDIR}/usr/share/makedumpfile-${VERSION}/eppic_scripts/ $(VPATH)eppic_scripts/*