summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-11-23 14:50:03 +0000
committerColin Watson <cjwatson@debian.org>2019-11-23 14:50:03 +0000
commit71b74e328b324df46dfaf524caedfc5f452066c1 (patch)
tree7a0554d09176d5c2b517befd87f4bee31a54da50
parent3fd2a98af023965e3f9e4d610e76fc8a981cf411 (diff)
Drop fdutimens patch for GNU/Hurd
The bug (https://bugs.debian.org/762677) that this was working around was fixed in glibc 2.28, or Debian glibc 2.27-2. * patches/fdutimens-hurd.patch: Remove. * bootstrap.conf (bootstrap_post_import_hook): Stop applying patches/fdutimens-hurd.patch. * Makefile.am (EXTRA_DIST): Remove patches/fdutimens-hurd.patch. * NEWS: Document this.
-rw-r--r--Makefile.am1
-rw-r--r--NEWS11
-rw-r--r--bootstrap.conf1
-rw-r--r--patches/fdutimens-hurd.patch37
4 files changed, 11 insertions, 39 deletions
diff --git a/Makefile.am b/Makefile.am
index af675881..8670d046 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,6 @@ EXTRA_DIST = \
bootstrap \
bootstrap.conf \
patches/argp-domain.patch \
- patches/fdutimens-hurd.patch \
release.sh
# These macro files are imported by gnulib-tool, but at present not used. We
diff --git a/NEWS b/NEWS
index 1236202e..aa8f3495 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,14 @@
+man-db 2.9.1
+============
+
+Major changes since man-db 2.9.0:
+
+ Improvements:
+ -------------
+
+ * Drop fdutimens patch for GNU/Hurd; the bug it was working around
+ was fixed in glibc 2.28.
+
man-db 2.9.0 (23 October 2019)
==============================
diff --git a/bootstrap.conf b/bootstrap.conf
index 9d7e32ec..d97ddc06 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -133,7 +133,6 @@ tar -
bootstrap_post_import_hook () {
patch -s -p1 <patches/argp-domain.patch
- patch -s -p1 <patches/fdutimens-hurd.patch
# gnulib-tool installs its own versions of gettext infrastructure files
# such as po/Makefile.in.in, which don't necessarily match our configured
diff --git a/patches/fdutimens-hurd.patch b/patches/fdutimens-hurd.patch
deleted file mode 100644
index de0d683f..00000000
--- a/patches/fdutimens-hurd.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-commit 15ab8fc0974755c0b56554b6dc6f9dec65290b8c
-Author: Colin Watson <cjwatson@debian.org>
-Date: Wed Sep 24 13:09:50 2014 +0100
-
- utimens: handle lack of UTIME_* on GNU/Hurd
-
- The Hurd has futimens, but does not currently support
- UTIME_NOW/UTIME_OMIT (https://bugs.debian.org/762677). Resolve these to
- real timestamps if necessary.
-
- Although the lutimens function is structured similarly, it does not need
- the same change because the Hurd does not have utimensat, so it will
- always fall back to other methods after calling update_timespec.
-
-diff --git a/gl/lib/utimens.c b/gl/lib/utimens.c
-index dd3ec66..2d0e9f6 100644
---- a/gl/lib/utimens.c
-+++ b/gl/lib/utimens.c
-@@ -243,6 +243,18 @@ fdutimens (int fd, char const *file, struct timespec const timespec[2])
- adjustment_needed++;
- }
- # endif
-+# ifdef __GNU__
-+ /* Work around lack of UTIME_NOW/UTIME_OMIT support:
-+ <https://bugs.debian.org/762677>. */
-+ if (adjustment_needed > 0)
-+ {
-+ if (fd < 0 ? stat (file, &st) : fstat (fd, &st))
-+ return -1;
-+ update_timespec (&st, &ts);
-+ /* Note that st is good, in case futimens gives ENOSYS. */
-+ adjustment_needed = 3;
-+ }
-+# endif
- # if HAVE_UTIMENSAT
- if (fd < 0)
- {