summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2013-06-26 22:35:24 +0100
committerColin Watson <cjwatson@debian.org>2013-06-26 22:35:24 +0100
commit9e03d70bb2298dd69cf6e94d43962934ae547303 (patch)
treefe83c3a82910cecd3d9ccadf5cf9770996668be8
parent4ab7113e13f9ae60931e60801cdc41b01baeaf3a (diff)
* configure.ac: Move check for whether nroff supports warning
control down below check for whether troff is groff, otherwise it always returns false. Reported by Niels Thykier. * NEWS: Document this.
-rw-r--r--ChangeLog7
-rw-r--r--NEWS11
-rwxr-xr-xconfigure47
-rw-r--r--configure.ac31
4 files changed, 60 insertions, 36 deletions
diff --git a/ChangeLog b/ChangeLog
index ccc6eb02..efb4fa5e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+Wed Jun 26 22:33:00 BST 2013 Colin Watson <cjwatson@debian.org>
+
+ * configure.ac: Move check for whether nroff supports warning
+ control down below check for whether troff is groff, otherwise it
+ always returns false. Reported by Niels Thykier.
+ * NEWS: Document this.
+
Sun Jun 23 22:50:24 BST 2013 Colin Watson <cjwatson@debian.org>
* Version: 2.6.4.
diff --git a/NEWS b/NEWS
index f733f3dc..4793d2b2 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,14 @@
+man-db 2.6.5
+============
+
+Major changes since man-db 2.6.4:
+
+ Fixes:
+ ------
+
+ o man's --warnings option works again on systems with versions of
+ groff that support it.
+
man-db 2.6.4 (23 June 2013)
===========================
diff --git a/configure b/configure
index b09e7a5e..7aab164a 100755
--- a/configure
+++ b/configure
@@ -15931,28 +15931,6 @@ $as_echo "ambiguous" >&6; }
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: please edit include/manconfig.h and add nroff definition" >&5
$as_echo "$as_me: WARNING: please edit include/manconfig.h and add nroff definition" >&2;}
fi
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether nroff supports warning control" >&5
-$as_echo_n "checking whether nroff supports warning control... " >&6; }
-if ${man_cv_prog_nroff_warnings+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- if test "x$troff_is_groff" = xyes && \
- nroff -wmac </dev/null >/dev/null 2>&1
- then
- man_cv_prog_nroff_warnings=yes
- else
- man_cv_prog_nroff_warnings=no
- fi
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $man_cv_prog_nroff_warnings" >&5
-$as_echo "$man_cv_prog_nroff_warnings" >&6; }
- if test "x$man_cv_prog_nroff_warnings" = xyes; then
-
-$as_echo "#define NROFF_WARNINGS 1" >>confdefs.h
-
- fi
else
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Cannot find an nroff-like program, formatting of manual page source will not be supported." >&5
$as_echo "$as_me: WARNING: Cannot find an nroff-like program, formatting of manual page source will not be supported." >&2;}
@@ -16106,6 +16084,31 @@ else
troff="(troff not installed)"
fi
+if test -n "$nroff"
+then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether nroff supports warning control" >&5
+$as_echo_n "checking whether nroff supports warning control... " >&6; }
+if ${man_cv_prog_nroff_warnings+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+
+ if test "x$troff_is_groff" = xyes && \
+ nroff -wmac </dev/null >/dev/null 2>&1
+ then
+ man_cv_prog_nroff_warnings=yes
+ else
+ man_cv_prog_nroff_warnings=no
+ fi
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $man_cv_prog_nroff_warnings" >&5
+$as_echo "$man_cv_prog_nroff_warnings" >&6; }
+ if test "x$man_cv_prog_nroff_warnings" = xyes; then
+
+$as_echo "#define NROFF_WARNINGS 1" >>confdefs.h
+
+ fi
+fi
+
for ac_prog in gpreconv preconv
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
diff --git a/configure.ac b/configure.ac
index 66de5720..f49e6ee3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,20 +219,6 @@ dnl nroff="$nroff ${man_cv_prog_nroff_macro}${nroff_device}"
AC_MSG_RESULT([ambiguous])
AC_MSG_WARN([please edit include/manconfig.h and add nroff definition])
fi
-
- AC_CACHE_CHECK([whether nroff supports warning control],
- [man_cv_prog_nroff_warnings], [
- if test "x$troff_is_groff" = xyes && \
- nroff -wmac </dev/null >/dev/null 2>&1
- then
- man_cv_prog_nroff_warnings=yes
- else
- man_cv_prog_nroff_warnings=no
- fi])
- if test "x$man_cv_prog_nroff_warnings" = xyes; then
- AC_DEFINE([NROFF_WARNINGS], [1],
- [Define if nroff supports warning control.])
- fi
else
AC_MSG_WARN([Cannot find an nroff-like program, formatting of manual page source will not be supported.])
nroff="(nroff not installed)"
@@ -290,6 +276,23 @@ else
troff="(troff not installed)"
fi
+if test -n "$nroff"
+then
+ AC_CACHE_CHECK([whether nroff supports warning control],
+ [man_cv_prog_nroff_warnings], [
+ if test "x$troff_is_groff" = xyes && \
+ nroff -wmac </dev/null >/dev/null 2>&1
+ then
+ man_cv_prog_nroff_warnings=yes
+ else
+ man_cv_prog_nroff_warnings=no
+ fi])
+ if test "x$man_cv_prog_nroff_warnings" = xyes; then
+ AC_DEFINE([NROFF_WARNINGS], [1],
+ [Define if nroff supports warning control.])
+ fi
+fi
+
AC_CHECK_PROGS([preconv], [gpreconv preconv])
AC_MSG_CHECKING([for groff with Debian multibyte patch or real Unicode support])