summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2023-07-22 13:00:07 +0100
committerColin Watson <cjwatson@debian.org>2023-07-22 13:00:07 +0100
commit54ec810261023af7686c62e34c142307b6ac0a6b (patch)
tree59a4e594a7204584c6d1c4ad2008ded1980b8f65
parent902612e4d4f8aad572f6b2e12a4ffe812d37e2d2 (diff)
Upgrade to Gnulib stable-202307
* bootstrap: Sync to Gnulib b7f7ed06961454cdf77b93c6c00c3e3f26202663. * bootstrap.conf (GNULIB_REVISION): Set to b7f7ed06961454cdf77b93c6c00c3e3f26202663. * src/tests/Makefile.am (fspause_LDADD): Link with `$(NANOSLEEP_LIB)` instead of `$(LIB_NANOSLEEP)`. * NEWS.md: Document this.
-rw-r--r--NEWS.md2
-rwxr-xr-xbootstrap21
-rw-r--r--bootstrap.conf2
-rw-r--r--src/tests/Makefile.am2
4 files changed, 11 insertions, 16 deletions
diff --git a/NEWS.md b/NEWS.md
index 37d9df7c..9f655f38 100644
--- a/NEWS.md
+++ b/NEWS.md
@@ -9,7 +9,7 @@ Fixes:
Improvements:
* Update system call lists in `seccomp` sandbox from `systemd`.
- * Upgrade to Gnulib `stable-202301`.
+ * Upgrade to Gnulib `stable-202307`.
* Work around the Firebuild accelerator in `seccomp` sandbox: if this is in
use then we need to allow some socket-related system calls.
* `man -K` now deduplicates search results that point to the same page.
diff --git a/bootstrap b/bootstrap
index 102927cf..93e000d1 100755
--- a/bootstrap
+++ b/bootstrap
@@ -37,7 +37,7 @@ medir=`dirname "$me"`
# A library of shell functions for autopull.sh, autogen.sh, and bootstrap.
-scriptlibversion=2022-12-27.16; # UTC
+scriptlibversion=2023-06-06.21; # UTC
# Copyright (C) 2003-2023 Free Software Foundation, Inc.
#
@@ -340,7 +340,7 @@ check_versions() {
# Handle the still-experimental Automake-NG programs specially.
# They remain named as the mainstream Automake programs ("automake",
# and "aclocal") to avoid gratuitous incompatibilities with
- # pre-existing usages (by, say, autoreconf, or custom autogen.sh
+ # preexisting usages (by, say, autoreconf, or custom autogen.sh
# scripts), but correctly identify themselves (as being part of
# "GNU automake-ng") when asked their version.
case $app in
@@ -815,7 +815,9 @@ autopull()
fi
fi
- echo "$0: done. Now you can run './autogen.sh'."
+ if test -f "$medir"/autogen.sh; then
+ echo "$0: done. Now you can run '$medir/autogen.sh'."
+ fi
}
# ----------------------------- Get translations. -----------------------------
@@ -976,7 +978,7 @@ symlink_to_dir()
for dot_ig in x $vc_ignore; do
test $dot_ig = x && continue
ig=$parent/$dot_ig
- insert_vc_ignore $ig "${dst_dir##*/}"
+ insert_vc_ignore $ig "${dst_dir##*/}/"
done
fi
@@ -1102,7 +1104,7 @@ autogen()
mkdir $build_aux
for dot_ig in x $vc_ignore; do
test $dot_ig = x && continue
- insert_vc_ignore $dot_ig $build_aux
+ insert_vc_ignore $dot_ig $build_aux/
done
fi
@@ -1234,14 +1236,7 @@ autogen()
# Invoke autoreconf with --force --install to ensure upgrades of tools
# such as ylwrap.
AUTORECONFFLAGS="--verbose --install --force -I $m4_base $ACLOCAL_FLAGS"
-
- # Some systems (RHEL 5) are using ancient autotools, for which the
- # --no-recursive option had not been invented. Detect that lack and
- # omit the option when it's not supported. FIXME in 2017: remove this
- # hack when RHEL 5 autotools are updated, or when they become irrelevant.
- case $($AUTORECONF --help) in
- *--no-recursive*) AUTORECONFFLAGS="$AUTORECONFFLAGS --no-recursive";;
- esac
+ AUTORECONFFLAGS="$AUTORECONFFLAGS --no-recursive"
# Tell autoreconf not to invoke autopoint or libtoolize; they were run above.
echo "running: AUTOPOINT=true LIBTOOLIZE=true $AUTORECONF $AUTORECONFFLAGS"
diff --git a/bootstrap.conf b/bootstrap.conf
index fee990f4..9496da61 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -16,7 +16,7 @@
# along with this program. If not, see <https://www.gnu.org/licenses/>.
-GNULIB_REVISION=c5dc86ca5c2e5c16177508bc32afe755b7995685
+GNULIB_REVISION=b7f7ed06961454cdf77b93c6c00c3e3f26202663
# gnulib modules used by this package.
gnulib_modules="
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index 05598766..4f0b872e 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -74,7 +74,7 @@ check_PROGRAMS = fspause get-mtime
fspause_SOURCES = fspause.c
fspause_LDADD = \
$(top_builddir)/gl/lib/libgnu.la \
- $(LIB_NANOSLEEP)
+ $(NANOSLEEP_LIB)
get_mtime_SOURCES = get-mtime.c
get_mtime_LDADD = $(top_builddir)/lib/libman.la