summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-10-05 10:37:02 +0100
committerColin Watson <cjwatson@debian.org>2010-10-05 10:37:02 +0100
commit44b09a483a2206527c803222567c60fc6a37b7df (patch)
tree1724bdea92b652fe6c48bf65f9fdcbd9c5feab2c /Makefile.am
parent00ab8261d9824d7838bac936930fbb70e0bc22f1 (diff)
It turns out that AM_GNU_GETTEXT([use-libtool]) is unsupported.
Switch to external libintl instead. * configure.ac (AM_GNU_GETTEXT): Set external. (AC_CONFIG_FILES): Remove intl/Makefile. * Makefile.am (SUBDIRS): Remove intl. (EXTRA_DIST): Add gnulib/m4/glibc2.m4, gnulib/m4/intdiv0.m4, gnulib/m4/intl.m4, gnulib/m4/intmax.m4, gnulib/m4/inttypes-pri.m4, gnulib/m4/lcmessage.m4, gnulib/m4/printf-posix.m4, gnulib/m4/uintmax_t.m4, and gnulib/m4/visibility.m4. * intl: Remove. * lib/Makefile.am (libman_la_CPPFLAGS): Remove -I$(top_builddir)/intl. * libdb/Makefile.am (libmandb_la_CPPFLAGS): Likewise. * src/Makefile.am (AM_CPPFLAGS): Likewise. * .bzrignore: Remove intl/Makefile, intl/charset.alias, intl/libgnuintl.h, intl/libintl.h, intl/ref-add.sed, and intl/ref-del.sed. * NEWS: Document this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b88c4d7..9593de43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@
## along with man-db; if not, write to the Free Software Foundation,
## Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-SUBDIRS = docs intl gnulib/lib gnulib/po lib libdb src man manual po tools
+SUBDIRS = docs gnulib/lib gnulib/po lib libdb src man manual po tools
dist_noinst_DATA = NEWS README include/README
@@ -35,8 +35,17 @@ EXTRA_DIST = \
# These macro files are imported by gnulib-tool, but at present not used. We
# include them in the distribution anyway for maximum consistency.
EXTRA_DIST += \
+ gnulib/m4/glibc2.m4 \
+ gnulib/m4/intdiv0.m4 \
+ gnulib/m4/intl.m4 \
gnulib/m4/intldir.m4 \
- gnulib/m4/sockpfaf.m4
+ gnulib/m4/intmax.m4 \
+ gnulib/m4/inttypes-pri.m4 \
+ gnulib/m4/lcmessage.m4 \
+ gnulib/m4/printf-posix.m4 \
+ gnulib/m4/sockpfaf.m4 \
+ gnulib/m4/uintmax_t.m4 \
+ gnulib/m4/visibility.m4
# Note that autopoint installs into the first directory here. Yes, this
# means that it installs into gnulib/m4, so we always run gnulib-tool after