summaryrefslogtreecommitdiff
path: root/bootstrap.conf
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-07-27 10:39:51 +0100
committerColin Watson <cjwatson@debian.org>2018-07-27 10:39:51 +0100
commitc4486722ce98e5d8014f28fc738720f25c9d5cc2 (patch)
tree8ad00f29e411a81c09350c7c88daf322dcd00833 /bootstrap.conf
parent2f29c2587f82c2afdb4352591e4d66292115bf43 (diff)
Work around Gnulib/gettext mismatch
The versions of gettext infrastructure files installed by gnulib-tool don't necessarily match our configured AM_GNU_GETTEXT_VERSION, so we need to fix things up in bootstrap. * bootstrap.conf (gnulib_tool_option_extras): Set --po-base to gl/ref-po rather than gnulib/po. (bootstrap_post_import_hook): Merge temporary gl/ref-po directory into gl/po.
Diffstat (limited to 'bootstrap.conf')
-rw-r--r--bootstrap.conf14
1 files changed, 13 insertions, 1 deletions
diff --git a/bootstrap.conf b/bootstrap.conf
index 896b087b..810cd154 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -71,7 +71,7 @@ gnulib_modules="
"
gnulib_tool_option_extras="\
- --po-base=gnulib/po \
+ --po-base=gl/ref-po \
--no-conditional-dependencies \
--libtool \
--macro-prefix=gl \
@@ -116,6 +116,18 @@ tar -
bootstrap_post_import_hook () {
patch -s -p1 <patches/argp-domain.patch
patch -s -p1 <patches/fdutimens-hurd.patch
+
+ # gnulib-tool installs its own versions of gettext infrastructure files
+ # such as po/Makefile.in.in, which don't necessarily match our configured
+ # AM_GNU_GETTEXT_VERSION. To cope with this, we tell gnulib-tool to
+ # install into a temporary directory (using --po-base above) and fix
+ # things up here.
+ cp -a gl/ref-po/LINGUAS gl/ref-po/POTFILES.in gl/po/
+ sed 's,^subdir *=.*,subdir = gl/po,' gl/ref-po/Makevars >gl/po/Makevars
+ if ls gl/ref-po/*.po >/dev/null 2>&1; then
+ cp -a gl/ref-po/*.po gl/po/
+ fi
+ rm -rf gl/ref-po
}
bootstrap_epilogue () {