summaryrefslogtreecommitdiff
path: root/bootstrap.conf
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-05-28 13:57:20 +0100
committerColin Watson <cjwatson@debian.org>2018-05-28 13:57:20 +0100
commitccff906eeeeb1a3f0d694db8d890cfdf76f54a9a (patch)
tree58a7b7e3e93502a8530b06ac121d3c3b7c6fdcf4 /bootstrap.conf
parent4a9046a49184b6395965bd15dc57b50cc643e0c6 (diff)
Switch to bootstrap
We no longer keep autogenerated files in git. * .gitignore: Add **/Makefile, **/Makefile.in, /ABOUT-NLS, /aclocal.m4, /build-aux, /config.h.in, /configure, /gl, /gnulib, docs/INSTALL.autoconf, po/Makefile.in.in, po/Makevars, po/Rules-quot, po/boldquot.sed, po/en@boldquot.header, po/en@quot.header, po/insert-header.sin, po/quot.sed, and po/remove-potcdate.sin. Remove docs/Makefile, gnulib/*, init/Makefile, init/systemd/Makefile, lib/Makefile, libdb/Makefile, man/Makefile, man/*/Makefile, manual/Makefile, po/Makefile, po/Makefile.in, src/Makefile, src/tests/Makefile, and tools/Makefile. * ABOUT-NLS, Makefile.in, aclocal.m4, autogen.sh, build-aux, config.h.in, configure, docs/INSTALL.autoconf, docs/Makefile.in, gnulib, init/Makefile.in, init/systemd/Makefile.in, lib/Makefile.in, libdb/Makefile.in, man/Makefile.in, man/da/Makefile.in, man/de/Makefile.in, man/es/Makefile.in, man/fr/Makefile.in, man/id/Makefile.in, man/it/Makefile.in, man/ja/Makefile.in, man/nl/Makefile.in, man/pl/Makefile.in, man/po4a/Makefile.in, man/pt_BR/Makefile.in, man/ru/Makefile.in, man/sr/Makefile.in, man/sv/Makefile.in, man/tr/Makefile.in, man/zh_CN/Makefile.in, manual/Makefile.in, po/Makefile.in.in, po/Makevars, po/Rules-quot, po/boldquot.sed, po/en@boldquot.header, po/en@quot.header, po/insert-header.sin, po/quot.sed, po/remove-potcdate.sin, src/Makefile.in, src/tests/Makefile.in, tools/Makefile.in: Remove. * bootstrap, bootstrap.conf: New files. * Makefile.am (GNULIB_PO, SUBDIRS, EXTRA_DIST, ACLOCAL_AMFLAGS): Refer to gl/ rather than gnulib/ (gnulib/ now contains pristine source). (EXTRA_DIST): Replace autogen.sh with bootstrap and bootstrap.conf. Replace gnulib/argp-domain.patch with patches/argp-domain.patch. Add patches/fdutimens-hurd.patch. Remove gnulib/m4/gnulib-cache.m4 and gnulib/m4/gnulib-tool.m4. * gnulib/argp-domain.patch: Rename to ... * patches/argp-domain.patch: ... this. Update target paths. * gnulib/fdutimens-hurd.patch: Rename to ... * patches/fdutimens-hurd.patch: ... this. Update target paths. * configure.ac (AM_GNU_GETTEXT_VERSION): Upgrade to 0.18.3, for compatibility with current Automake. (HAVE_GNULIB_PO, AC_CONFIG_FILES): Refer to gl/ rather than gnulib/. * lib/Makefile.am (libman_la_CPPFLAGS, libman_la_LIBADD): Likewise. * libdb/Makefile.am (libmandb_la_CPPFLAGS): Likewise. * src/Makefile.am (AM_CPPFLAGS, LIBMAN): Likewise. * src/tests/Makefile.am (AM_CPPFLAGS, fspause_LDADD): Likewise. * docs/HACKING: Describe new policy. * release.sh: Call ./bootstrap rather than ./autogen.sh.
Diffstat (limited to 'bootstrap.conf')
-rw-r--r--bootstrap.conf124
1 files changed, 124 insertions, 0 deletions
diff --git a/bootstrap.conf b/bootstrap.conf
new file mode 100644
index 00000000..02c5d92f
--- /dev/null
+++ b/bootstrap.conf
@@ -0,0 +1,124 @@
+# Bootstrap configuration.
+
+# Copyright (C) 2006-2018 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+
+GNULIB_URL=git://erislabs.net/gnulib.git
+GNULIB_REVISION=stable/20140202
+
+# gnulib modules used by this package.
+gnulib_modules="
+ argp
+ canonicalize
+ closedir
+ dirent
+ dirname
+ error
+ flock
+ fnmatch-gnu
+ fstat
+ futimens
+ getline
+ getopt-gnu
+ gettext
+ gitlog-to-changelog
+ glob
+ gnupload
+ idpriv-drop
+ idpriv-droptemp
+ lib-ignore
+ localcharset
+ lock
+ memmem
+ minmax
+ mkdtemp
+ mkstemp
+ nanosleep
+ nonblocking
+ openat
+ opendir
+ regex
+ rename
+ setenv
+ sigaction
+ signal
+ sigprocmask
+ stat-time
+ strcasestr
+ strerror
+ strsep
+ timespec
+ unsetenv
+ utimens
+ warnings
+ xalloc
+ xgetcwd
+ xstrndup
+ xvasprintf
+"
+
+gnulib_tool_option_extras="\
+ --po-base=gnulib/po \
+ --no-conditional-dependencies \
+ --libtool \
+ --macro-prefix=gl \
+ --po-domain=man-db \
+ --no-vc-files \
+ --no-cache-modules \
+"
+
+gnulib_name=libgnu
+source_base=gl/lib
+m4_base=gl/m4
+
+COPYRIGHT_HOLDER='Colin Watson <cjwatson@debian.org>'
+MSGID_BUGS_ADDRESS="$COPYRIGHT_HOLDER"
+
+# Additional xgettext options to use. Use "\\\newline" to break lines.
+XGETTEXT_OPTIONS=$XGETTEXT_OPTIONS'\\\
+ --from-code=UTF-8\\\
+ --flag=debug:1:c-format\\\
+ --flag=debug_error:1:c-format\\\
+'
+
+checkout_only_file=
+copy=true
+vc_ignore=
+
+SKIP_PO=t
+
+# Build prerequisites
+buildreq="\
+autoconf 2.59
+automake 1.11
+autopoint 0.18.1
+gettext 0.18.1
+git 1.5.5
+tar -
+"
+
+# Remove any previous import before running gnulib-tool, as otherwise it
+# seems to keep patched files around from previous runs.
+rm -rf gl
+
+bootstrap_post_import_hook () {
+ patch -s -p1 <patches/argp-domain.patch
+ patch -s -p1 <patches/fdutimens-hurd.patch
+}
+
+bootstrap_epilogue () {
+ mv INSTALL docs/INSTALL.autoconf
+}