summaryrefslogtreecommitdiff
path: root/bootstrap
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-07-27 09:37:42 +0100
committerColin Watson <cjwatson@debian.org>2018-07-27 09:37:42 +0100
commit2f29c2587f82c2afdb4352591e4d66292115bf43 (patch)
tree45e943907504009c95006df14d8faca3907f526b /bootstrap
parent0a1703c25877c56d474db4c971442638d531c23f (diff)
Upgrade to Gnulib 20180726
* bootstrap: Sync to Gnulib 900ca5c0b092e50f9f17329feea3fbfe2b6e2139. * bootstrap.conf (GNULIB_REVISION): Set to 900ca5c0b092e50f9f17329feea3fbfe2b6e2139.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap21
1 files changed, 12 insertions, 9 deletions
diff --git a/bootstrap b/bootstrap
index 002edf68..fa9d7c94 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
#! /bin/sh
# Print a version string.
-scriptversion=2018-05-27.20; # UTC
+scriptversion=2018-07-25.07; # UTC
# Bootstrap this package from checked-out sources.
@@ -142,6 +142,9 @@ die() { warn_ "$@"; exit 1; }
# Configuration.
+# Name of the Makefile.am
+gnulib_mk=gnulib.mk
+
# List of gnulib modules needed.
gnulib_modules=
@@ -165,7 +168,7 @@ bootstrap_epilogue() { :; }
# options because the latest/%s directory and the .po files within are
# all symlinks.
po_download_command_format=\
-"rsync --delete --exclude '*.s1' -Lrtvz \
+"rsync --include '*.po' --exclude '*' -Lrtvz \
'translationproject.org::tp/latest/%s/' '%s'"
# Fallback for downloading .po files (if rsync fails).
@@ -942,13 +945,13 @@ fi
if $use_gnulib; then
gnulib_tool_options="\
--no-changelog\
- --aux-dir $build_aux\
- --doc-base $doc_base\
- --lib $gnulib_name\
- --m4-base $m4_base/\
- --source-base $source_base/\
- --tests-base $tests_base\
- --local-dir $local_gl_dir\
+ --aux-dir=$build_aux\
+ --doc-base=$doc_base\
+ --lib=$gnulib_name\
+ --m4-base=$m4_base/\
+ --source-base=$source_base/\
+ --tests-base=$tests_base\
+ --local-dir=$local_gl_dir\
$gnulib_tool_option_extras\
"
if test $use_libtool = 1; then