summaryrefslogtreecommitdiff
path: root/bootstrap
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-01-05 11:47:47 +0000
committerColin Watson <cjwatson@debian.org>2019-01-05 11:47:47 +0000
commit23ccce2d05338688fd9fed7045e7d6660f5b3fc4 (patch)
tree7d7d75b121c59f3cb86a3149e9bf8915aaf9eca0 /bootstrap
parentc588541ab548aa093b6b31196ae3cff7bb9250fe (diff)
Upgrade to Gnulib 20190105
In line with Gnulib, we now require Autoconf 2.63 and Automake 1.11.2. * bootstrap: Sync to Gnulib d271f868a8df9bbec29049d01e056481b7a1a263. * bootstrap.conf (GNULIB_REVISION): Set to d271f868a8df9bbec29049d01e056481b7a1a263. (buildreq): Bump required autoconf version to 2.63 and required automake version to 1.11.2. * configure.ac (AM_SILENT_RULES, AM_PROG_AR): Remove conditionals, which were there for Automake 1.10 support. (AC_PREREQ): Bump to 2.63. * NEWS: Document this.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap34
1 files changed, 17 insertions, 17 deletions
diff --git a/bootstrap b/bootstrap
index fa9d7c94..5b08e7e2 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,10 +1,10 @@
#! /bin/sh
# Print a version string.
-scriptversion=2018-07-25.07; # UTC
+scriptversion=2019-01-04.17; # UTC
# Bootstrap this package from checked-out sources.
-# Copyright (C) 2003-2018 Free Software Foundation, Inc.
+# Copyright (C) 2003-2019 Free Software Foundation, Inc.
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -162,18 +162,11 @@ bootstrap_post_import_hook() { :; }
# Override it via your own definition in bootstrap.conf.
bootstrap_epilogue() { :; }
-# The command to download all .po files for a specified domain into
-# a specified directory. Fill in the first %s is the domain name, and
-# the second with the destination directory. Use rsync's -L and -r
-# options because the latest/%s directory and the .po files within are
-# all symlinks.
+# The command to download all .po files for a specified domain into a
+# specified directory. Fill in the first %s with the destination
+# directory and the second with the domain name.
po_download_command_format=\
-"rsync --include '*.po' --exclude '*' -Lrtvz \
- 'translationproject.org::tp/latest/%s/' '%s'"
-
-# Fallback for downloading .po files (if rsync fails).
-po_download_command_format2=\
-"wget --mirror -nd -q -np -A.po -P '%s' \
+"wget --mirror --level=1 -nd -q -A.po -P '%s' \
https://translationproject.org/latest/%s/"
# Prefer a non-empty tarname (4th argument of AC_INIT if given), else
@@ -741,10 +734,7 @@ download_po_files() {
subdir=$1
domain=$2
echo "$me: getting translations into $subdir for $domain..."
- cmd=$(printf "$po_download_command_format" "$domain" "$subdir")
- eval "$cmd" && return
- # Fallback to HTTPS.
- cmd=$(printf "$po_download_command_format2" "$subdir" "$domain")
+ cmd=$(printf "$po_download_command_format" "$subdir" "$domain")
eval "$cmd"
}
@@ -973,6 +963,16 @@ fi
bootstrap_post_import_hook \
|| die "bootstrap_post_import_hook failed"
+# Don't proceed if there are uninitialized submodules. In particular,
+# the next step will remove dangling links, which might be links into
+# uninitialized submodules.
+#
+# Uninitialized submodules are listed with an initial dash.
+if $use_git && git submodule | grep '^-' >/dev/null; then
+ die "some git submodules are not initialized. " \
+ "Run 'git submodule init' and bootstrap again."
+fi
+
# Remove any dangling symlink matching "*.m4" or "*.[ch]" in some
# gnulib-populated directories. Such .m4 files would cause aclocal to fail.
# The following requires GNU find 4.2.3 or newer. Considering the usual