summaryrefslogtreecommitdiff
path: root/config.h.in
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-09-24 00:58:57 +0100
committerColin Watson <cjwatson@debian.org>2014-09-24 00:58:57 +0100
commitbea294a14a136e9ef7c0ed36a62bca68e9ff272e (patch)
treea289d27ad6e31317bae1dc95a658957ba90ab4a1 /config.h.in
parentfe340c4a3c1ed567d8cbaa7a40e3c0b82edf4520 (diff)
Fix tests when build fs does not support high-precision timestamps
* gnulib: Import nanosleep module. * configure.ac: Remove STAT_HAS_NSEC substitution. * src/tests/Makefile.am (TESTS_ENVIRONMENT): Stop exporting STAT_HAS_NSEC. (AM_CPPFLAGS, AM_CFLAGS, check_PROGRAMS, fspause_SOURCES, fspause_LDADD): Add. * src/tests/fspause.c: New file. * src/tests/mandb-2, src/tests/mandb-3, src/tests/mandb-4, src/tests/mandb-5: Call ./fspause rather than next_second. * src/tests/testlib.sh (next_second): Remove. * .gitignore: Add src/tests/.deps and src/tests/fspause. * NEWS: Document this.
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/config.h.in b/config.h.in
index 67e79727..c6152191 100644
--- a/config.h.in
+++ b/config.h.in
@@ -257,6 +257,9 @@
/* Define to 1 when the gnulib module mkstemp should be tested. */
#undef GNULIB_TEST_MKSTEMP
+/* Define to 1 when the gnulib module nanosleep should be tested. */
+#undef GNULIB_TEST_NANOSLEEP
+
/* Define to 1 when the gnulib module nl_langinfo should be tested. */
#undef GNULIB_TEST_NL_LANGINFO
@@ -302,6 +305,9 @@
/* Define to 1 when the gnulib module secure_getenv should be tested. */
#undef GNULIB_TEST_SECURE_GETENV
+/* Define to 1 when the gnulib module select should be tested. */
+#undef GNULIB_TEST_SELECT
+
/* Define to 1 when the gnulib module setenv should be tested. */
#undef GNULIB_TEST_SETENV
@@ -370,6 +376,9 @@
/* Define to 1 if you have the 'btowc' function. */
#undef HAVE_BTOWC
+/* Define to 1 if nanosleep mishandles large arguments. */
+#undef HAVE_BUG_BIG_NANOSLEEP
+
/* Define if you have bzip2. */
#undef HAVE_BZIP2
@@ -1160,6 +1169,9 @@
/* Define to 1 if pread is declared even after undefining macros. */
#undef HAVE_RAW_DECL_PREAD
+/* Define to 1 if pselect is declared even after undefining macros. */
+#undef HAVE_RAW_DECL_PSELECT
+
/* Define to 1 if pthread_sigmask is declared even after undefining macros. */
#undef HAVE_RAW_DECL_PTHREAD_SIGMASK
@@ -1217,6 +1229,9 @@
/* Define to 1 if secure_getenv is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SECURE_GETENV
+/* Define to 1 if select is declared even after undefining macros. */
+#undef HAVE_RAW_DECL_SELECT
+
/* Define to 1 if send is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SEND
@@ -1693,6 +1708,9 @@
/* Define to 1 if you have the <sys/param.h> header file. */
#undef HAVE_SYS_PARAM_H
+/* Define to 1 if you have the <sys/select.h> header file. */
+#undef HAVE_SYS_SELECT_H
+
/* Define to 1 if you have the <sys/socket.h> header file. */
#undef HAVE_SYS_SOCKET_H
@@ -2063,6 +2081,9 @@
'wchar_t'. */
#undef WCHAR_T_SUFFIX
+/* Define if WSAStartup is needed. */
+#undef WINDOWS_SOCKETS
+
/* Define to l, ll, u, ul, ull, etc., as suitable for constants of type
'wint_t'. */
#undef WINT_T_SUFFIX