summaryrefslogtreecommitdiff
path: root/config.h.in
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-12-19 16:11:13 +0000
committerColin Watson <cjwatson@debian.org>2010-12-19 16:11:13 +0000
commitf7658f51c254ce16a564d670880d828a00f3a3fc (patch)
tree5927055ee2e7b194923fa3efef638a6cca670aad /config.h.in
parent2e6a28c3f67527a4a1eb87a26a011bb62d95ee09 (diff)
* gnulib: Import idpriv-drop and idpriv-droptemp modules.
* configure.ac: Stop checking for seteuid, setreuid, and setresuid. * lib/security.c (POSIX_SAVED_IDS, SET_EUID, SWAP_UIDS): Remove in favour of idpriv.h. (drop_effective_privs): Use idpriv_temp_drop. (regain_effective_privs): Use idpriv_temp_restore. (do_system_drop_privs): Use idpriv_drop. Drop saved-IDs case; avoiding a fork doesn't justify having two code paths.
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/config.h.in b/config.h.in
index 92453a4d..66f55dfa 100644
--- a/config.h.in
+++ b/config.h.in
@@ -552,6 +552,15 @@
/* Define to 1 if you have the `getdtablesize' function. */
#undef HAVE_GETDTABLESIZE
+/* Define to 1 if you have the `getegid' function. */
+#undef HAVE_GETEGID
+
+/* Define to 1 if you have the `geteuid' function. */
+#undef HAVE_GETEUID
+
+/* Define to 1 if you have the `getgid' function. */
+#undef HAVE_GETGID
+
/* Define to 1 if you have the `getlogin_r' function. */
#undef HAVE_GETLOGIN_R
@@ -567,12 +576,21 @@
/* Define to 1 if you have the `getpwnam_r' function. */
#undef HAVE_GETPWNAM_R
+/* Define to 1 if you have the `getresgid' function. */
+#undef HAVE_GETRESGID
+
+/* Define to 1 if you have the `getresuid' function. */
+#undef HAVE_GETRESUID
+
/* Define if the GNU gettext() function is already present or preinstalled. */
#undef HAVE_GETTEXT
/* Define to 1 if you have the `gettimeofday' function. */
#undef HAVE_GETTIMEOFDAY
+/* Define to 1 if you have the `getuid' function. */
+#undef HAVE_GETUID
+
/* Define to 1 if you have the <glob.h> header file. */
#undef HAVE_GLOB_H
@@ -1161,12 +1179,21 @@
/* Define to 1 if you have the <search.h> header file. */
#undef HAVE_SEARCH_H
+/* Define to 1 if you have the `setegid' function. */
+#undef HAVE_SETEGID
+
/* Define to 1 if you have the `setenv' function. */
#undef HAVE_SETENV
/* Define to 1 if you have the `seteuid' function. */
#undef HAVE_SETEUID
+/* Define to 1 if you have the `setregid' function. */
+#undef HAVE_SETREGID
+
+/* Define to 1 if you have the `setresgid' function. */
+#undef HAVE_SETRESGID
+
/* Define to 1 if you have the `setresuid' function. */
#undef HAVE_SETRESUID