summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-09-01 00:18:16 +0100
committerColin Watson <cjwatson@debian.org>2019-09-01 00:24:57 +0100
commit2e87aaf19e4f348097c91da9612e7b46d1d7a572 (patch)
tree1d20335a9962c9983c6f3140cb66ee335b890e15 /configure.ac
parent16c6798b923893eeef6f6973e9400bfbb219d6e2 (diff)
Remove ability to undefine COMP_SRC
This was a minor optimisation that wasn't worth the extra code complexity. * configure.ac (COMP_SRC): Remove. * include/comp_src.h.in: Remove COMP_SRC conditional. comp_list will simply contain only the terminal entry if no compressors are configured. * include/manconfig.h.in: Remove COMP_SRC conditional and comment. * manual/comp.me (Compressed manual pages): Remove documentation of COMP_SRC; explain that support depends on the decompressors available at configure time. * src/compression.c: Remove COMP_SRC conditional. (comp_info): Only do the HP-UX check if gunzip is available. * src/filenames.c (make_filename): Remove parenthetical comment about COMP_SRC. (filename_info): Remove COMP_SRC conditionals. * src/man.c (convert_name): Likewise. * src/straycats.c (check_for_stray): Likewise. * src/ult_src.c (ult_src): Likewise. * NEWS: Document this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a98704da..0cbd9c28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -321,7 +321,6 @@ fi
if test -n "$gzip" || test -n "$compress" || test -n "$bzip2" || test -n "$xz" || test -n "$lzip" || test -n "$lzma"
then
AC_DEFINE([COMP_CAT], [1], [Define if you have compressors and want to support compressed cat files.])
- AC_DEFINE([COMP_SRC], [1], [Define if you have compressors and want to support compressed manual source.])
fi
AC_SUBST([compressor])
AC_SUBST([compress_ext])