summaryrefslogtreecommitdiff
path: root/gnulib/lib/unistd--.h
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2007-12-13 11:39:01 +0000
committerColin Watson <cjwatson@debian.org>2007-12-13 11:39:01 +0000
commit4ff30791b6fe2c2a13c1d5a77a17013e7a931317 (patch)
treef81b3feb6693085faae8ea277a985355441411b2 /gnulib/lib/unistd--.h
parent7fcab0fcb1622b4c8e7c54d32d5555bfd673676f (diff)
* configure.ac (AM_GNU_GETTEXT_VERSION): Upgrade to gettext 0.17.
* gnulib: Upgrade to Debian 20071201+dfsg-1. * README (Copyright and licensing): New section. Explain the implications of Gnulib components being distributed under GPL v3. * .bzrignore: Ignore gnulib/lib/fcntl.h.
Diffstat (limited to 'gnulib/lib/unistd--.h')
-rw-r--r--gnulib/lib/unistd--.h27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnulib/lib/unistd--.h b/gnulib/lib/unistd--.h
new file mode 100644
index 00000000..1a7fd785
--- /dev/null
+++ b/gnulib/lib/unistd--.h
@@ -0,0 +1,27 @@
+/* Like unistd.h, but redefine some names to avoid glitches.
+
+ Copyright (C) 2005 Free Software Foundation, Inc.
+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
+
+/* Written by Paul Eggert. */
+
+#include <unistd.h>
+#include "unistd-safer.h"
+
+#undef dup
+#define dup dup_safer
+
+#undef pipe
+#define pipe pipe_safer