summaryrefslogtreecommitdiff
path: root/gnulib
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-03-11 01:28:28 +0000
committerColin Watson <cjwatson@debian.org>2010-03-11 01:28:28 +0000
commitfb4afb0b75a61b68d8d6fc755f491aa3f99b2a1f (patch)
tree3ee5d6ff76985c91a15315b101fea0df8cc90cc2 /gnulib
parent10fd7f78f3d5a658287117a15683c987c80cd80c (diff)
* configure.ac: Add AM_MAINTAINER_MODE. In the modern world,
timestamps are often just too fragile for those make targets to work well; use ./autogen.sh instead.
Diffstat (limited to 'gnulib')
-rw-r--r--gnulib/lib/Makefile.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnulib/lib/Makefile.in b/gnulib/lib/Makefile.in
index 265ea30a..5b0a5be8 100644
--- a/gnulib/lib/Makefile.in
+++ b/gnulib/lib/Makefile.in
@@ -732,6 +732,7 @@ LTLIBMULTITHREAD = @LTLIBMULTITHREAD@
LTLIBOBJS = @LTLIBOBJS@
LTLIBPTH = @LTLIBPTH@
LTLIBTHREAD = @LTLIBTHREAD@
+MAINT = @MAINT@
MAKEINFO = @MAKEINFO@
MAN_SUBDIRS = @MAN_SUBDIRS@
MKDIR_P = @MKDIR_P@
@@ -1166,7 +1167,7 @@ all: $(BUILT_SOURCES)
.SUFFIXES:
.SUFFIXES: .sed .sin .c .o .obj
-$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
+$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__configure_deps)
@for dep in $?; do \
case '$(am__configure_deps)' in \
*$$dep*) \
@@ -1191,9 +1192,9 @@ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-$(top_srcdir)/configure: $(am__configure_deps)
+$(top_srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-$(ACLOCAL_M4): $(am__aclocal_m4_deps)
+$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
$(am__aclocal_m4_deps):