summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-10-12 11:16:51 +0100
committerColin Watson <cjwatson@debian.org>2010-10-12 11:16:51 +0100
commitb44fcf32603a6e20c200397b66b377566f66b564 (patch)
tree86a45889bc9e57389c00cc9307035890b2c8c3e1 /include
parentd0b4f02ed5a0bcf246145993dab0524d606c7d2c (diff)
* lib/util.c (init_locale): New function.
* include/manconfig.h.in (init_locale): Add prototype. * src/Makefile.am (AM_CPPFLAGS): Move -DLOCALEDIR to ... * lib/Makefile.am (libman_la_CPPFLAGS): ... here. * src/accessdb.c (main), src/catman.c (main), src/globbing_test.c (main), src/lexgrog_test.c (main), src/man.c (main), src/manconv_main.c (main), src/mandb.c (main), src/manpath.c (main), src/whatis.c (main), src/zsoelim.c (main): Use init_locale. * lib/util.c (init_locale): Suppress warning message if DPKG_RUNNING_VERSION is set in the environment. * NEWS: Document this.
Diffstat (limited to 'include')
-rw-r--r--include/manconfig.h.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/manconfig.h.in b/include/manconfig.h.in
index 78b5edf2..ef2fba5c 100644
--- a/include/manconfig.h.in
+++ b/include/manconfig.h.in
@@ -365,6 +365,7 @@ extern char *escape_shell (const char *unesc);
extern int remove_directory (const char *directory);
extern char *trim_spaces (const char *s);
extern char *lang_dir (const char *filename);
+extern char *init_locale (int category, const char *locale);
extern char *appendstr (char *, ...)
ATTRIBUTE_SENTINEL ATTRIBUTE_WARN_UNUSED_RESULT;