summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorDarren Salt <linux@youmustbejoking.demon.co.uk>2010-03-03 00:11:23 +0000
committerColin Watson <cjwatson@debian.org>2010-03-03 00:11:23 +0000
commit10fd7f78f3d5a658287117a15683c987c80cd80c (patch)
treea46723223bb40ae9588ad480aaac965f88cb1e82 /include
parent3cff488b1d303987c9b2f6acdcca5a42c78c14ec (diff)
Add support for XZ-compressed manual pages (Debian bug #572233).
* configure.ac: Check for xz. * include/comp_src.h.in (comp_list): Add xz. * include/manconfig.h.in: Define UNXZ. * NEWS: Document this.
Diffstat (limited to 'include')
-rw-r--r--include/comp_src.h.in5
-rw-r--r--include/manconfig.h.in1
2 files changed, 6 insertions, 0 deletions
diff --git a/include/comp_src.h.in b/include/comp_src.h.in
index 45a66e68..7104c469 100644
--- a/include/comp_src.h.in
+++ b/include/comp_src.h.in
@@ -67,6 +67,11 @@ struct compression comp_list[] = {
{UNLZMA, "lzma", NULL},
#endif /* HAVE_LZMA */
+/* If we have xz, incorporate the following */
+#ifdef HAVE_XZ
+ {UNXZ, "xz", NULL},
+#endif /* HAVE_XZ */
+
/*------------------------------------------------------*/
/* Add your decompressor(s) and extension(s) below here */
/*------------------------------------------------------*/
diff --git a/include/manconfig.h.in b/include/manconfig.h.in
index 337d78b0..3c1c6312 100644
--- a/include/manconfig.h.in
+++ b/include/manconfig.h.in
@@ -220,6 +220,7 @@
# define UNCOMPRESS "@uncompress@"
# define BUNZIP2 "@bunzip2@"
# define UNLZMA "@unlzma@"
+# define UNXZ "@unxz@"
#endif /* COMP_SRC */
/*-----------------------------------------------------------------------*/