summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-09-23 22:07:55 +0100
committerColin Watson <cjwatson@debian.org>2022-09-23 22:07:55 +0100
commit312e096ceb9e41f1d96734a0734934e89e9226ad (patch)
tree87eabeb03b6bd56dafbe17ee6ec792bbef29268c /lib/Makefile.am
parent4cbb67968dd3db7f0140ca50489683c892cd5a10 (diff)
Move compression file name utilities to lib/
This makes more sense as a home for plain file name manipulation utilities. I also merged `include/comp_src.h.in` into `lib/compression.c`, because structure definitions (as opposed to declarations) don't belong in header files. * src/compression.c: Move to ... * lib/compression.c: ... here. Remove unnecessary `pipeline.h` include. * src/compression.h: Move to ... * lib/compression.h: ... here. Update positioning of all includes. * lib/Makefile.am (libman_la_SOURCES): Add `compression.c` and `compression.h`. * lib/README: Add `compression.*`. * src/Makefile.am (lexgrog_SOURCES, man_SOURCES, man_recode_SOURCES, mandb_SOURCES): Remove `compression.c` and `compression.h`. * include/comp_src.h (comp_list): Move to ... * lib/compression.c (comp_list): ... here. Update all references. * include/manconfig.h (struct compression, comp_list): Move to ... * lib/compression.h (struct compression, comp_list): ... here. Add includes where necessary. * Makefile.am (noinst_HEADERS): Remove `include/comp_src.h`.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 49f7809f..449f3356 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -36,6 +36,8 @@ libman_la_SOURCES = \
appendstr.h \
cleanup.c \
cleanup.h \
+ compression.c \
+ compression.h \
debug.c \
debug.h \
encodings.c \