summaryrefslogtreecommitdiff
path: root/lib/tempfile.c
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2009-07-14 22:50:42 +0100
committerColin Watson <cjwatson@debian.org>2009-07-14 22:50:42 +0100
commite9d12d5ce4b1670cb621a66cc7c8cadf38242dc9 (patch)
treeaf3d4eb40ab3727b9d5cfb9ff3e440759cc4b3bf /lib/tempfile.c
parent80a5599391c20d42aff0bd3d7c0c3b28344b7510 (diff)
* configure.ac: Add -Wredundant-decls to CFLAGS.
* lib/tempfile.c: Remove redundant declarations of mkstemp and mkdtemp. * src/manp.c: Remove redundant and unused declaration of program_name. * src/zsoelim.l: Add never-interactive option, partly because that's reasonably accurate anyway and partly to suppress flex's redundant declaration of isatty.
Diffstat (limited to 'lib/tempfile.c')
-rw-r--r--lib/tempfile.c4
1 files changed, 0 insertions, 4 deletions
diff --git a/lib/tempfile.c b/lib/tempfile.c
index 2fa44e6b..5ab4abfc 100644
--- a/lib/tempfile.c
+++ b/lib/tempfile.c
@@ -30,10 +30,6 @@
#include "manconfig.h"
-/* Other library functions used in man-db. */
-extern int mkstemp (char *template);
-extern char *mkdtemp (char *template);
-
static const char *path_search (void)
{
const char *dir = NULL;