summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-16 16:45:46 +0000
committerColin Watson <cjwatson@debian.org>2022-01-16 16:45:46 +0000
commit4e3a383c3a7a47533b047c8fde509d990058bbdd (patch)
treec9d848c58e1f2660c89b2d1b09abed6a9ac5d7ca /lib
parent1b32c829e19e4d47776274d9d8b5b59345cb7c56 (diff)
Move util.c-related declarations out of manconfig.h
* include/manconfig.h (is_changed, is_directory, escape_shell, remove_directory, trim_spaces, lang_dir, init_locale): Move to ... * lib/util.h: ... here (new file). * lib/Makefile.am (libman_la_SOURCES): Add util.h. * lib/util.c, src/accessdb.c, src/catman.c, src/check_mandirs.c, src/descriptions.c, src/globbing.c, src/globbing_test.c, src/lexgrog.l, src/lexgrog_test.c, src/man-recode.c, src/man.c, src/manconv_main.c, src/mandb.c, src/manp.c, src/manpath.c, src/straycats.c, src/whatis.c, src/zsoelim_main.c: Include util.h.
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.am1
-rw-r--r--lib/util.c1
-rw-r--r--lib/util.h31
3 files changed, 33 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index cc345c5f..2f134f04 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -54,6 +54,7 @@ libman_la_SOURCES = \
security.h \
tempfile.c \
util.c \
+ util.h \
wordfnmatch.c \
wordfnmatch.h \
xregcomp.c \
diff --git a/lib/util.c b/lib/util.c
index e3bc6e2d..5fac3ea6 100644
--- a/lib/util.c
+++ b/lib/util.c
@@ -56,6 +56,7 @@
#include "error.h"
#include "pipeline.h"
+#include "util.h"
/*
* Does file a have a different timestamp to file b?
diff --git a/lib/util.h b/lib/util.h
new file mode 100644
index 00000000..48c98440
--- /dev/null
+++ b/lib/util.h
@@ -0,0 +1,31 @@
+/*
+ * util.h
+ *
+ * Copyright (C) 1990, 1991 John W. Eaton.
+ * Copyright (C) 1994, 1995 Graeme W. Wilford. (Wilf.)
+ * Copyright (C) 2001-2022 Colin Watson.
+ *
+ * This file is part of man-db.
+ *
+ * man-db is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * man-db is distributed in the hope that it will be useful, but
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with man-db; if not, write to the Free Software Foundation,
+ * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+extern int is_changed (const char *fa, const char *fb);
+extern int is_directory (const char *path);
+extern char *escape_shell (const char *unesc);
+extern int remove_directory (const char *directory, int recurse);
+extern char *trim_spaces (const char *s);
+extern char *lang_dir (const char *filename);
+extern void init_locale (void);