summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2021-02-08 23:19:40 +0000
committerColin Watson <cjwatson@debian.org>2021-02-08 23:19:40 +0000
commita2d4ffce13a855f29a63bac2099ebe0f5a4e50bd (patch)
treedd12cc58c6d4cfb5e2c1183f47757295ce3b5662 /lib
parent6101e54adb4bd178f95b42ea3ed6a0b62da757bf (diff)
parent33fe5d77bd9908e3daf9fc868540ea24bca0b318 (diff)
Import man-db_2.9.4.orig.tar.xz
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.in2
-rw-r--r--lib/orderfiles.c2
-rw-r--r--lib/sandbox.c3
3 files changed, 4 insertions, 3 deletions
diff --git a/lib/Makefile.in b/lib/Makefile.in
index 4b1d992f..872757c6 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -1,4 +1,4 @@
-# Makefile.in generated by automake 1.16.2 from Makefile.am.
+# Makefile.in generated by automake 1.16.3 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2020 Free Software Foundation, Inc.
diff --git a/lib/orderfiles.c b/lib/orderfiles.c
index b235e192..bc12c88a 100644
--- a/lib/orderfiles.c
+++ b/lib/orderfiles.c
@@ -123,7 +123,7 @@ void order_files (const char *dir, gl_list_t *basenamesp)
if (ioctl (fd, FS_IOC_FIEMAP, (unsigned long) &fm) == 0) {
uint64_t *offset = XMALLOC (uint64_t);
- *offset = fm.fiemap.fm_extents[0].fe_physical;
+ *offset = fm.extent.fe_physical;
/* Borrow the key from basenames; since
* physical_offsets has a shorter lifetime, we don't
* need to duplicate it.
diff --git a/lib/sandbox.c b/lib/sandbox.c
index 21ec28aa..d934a0f9 100644
--- a/lib/sandbox.c
+++ b/lib/sandbox.c
@@ -232,7 +232,7 @@ static scmp_filter_ctx make_seccomp_filter (int permissive)
;
debug ("initialising seccomp filter (permissive: %d)\n", permissive);
- ctx = seccomp_init (SCMP_ACT_ERRNO (EPERM));
+ ctx = seccomp_init (SCMP_ACT_ERRNO (ENOSYS));
if (!ctx)
error (FATAL, errno, "can't initialise seccomp filter");
@@ -271,6 +271,7 @@ static scmp_filter_ctx make_seccomp_filter (int permissive)
/* systemd: SystemCallFilter=@default */
SC_ALLOW ("clock_getres");
SC_ALLOW ("clock_gettime");
+ SC_ALLOW ("clock_gettime64");
SC_ALLOW ("clock_nanosleep");
SC_ALLOW ("execve");
SC_ALLOW ("exit");