summaryrefslogtreecommitdiff
path: root/man/pl/Makefile.in
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2015-09-22 15:17:39 +0100
committerColin Watson <cjwatson@debian.org>2015-09-22 15:17:39 +0100
commit32ee575a45d3a7e221a7b29c457049b659315152 (patch)
treeb5c5ad0896f7c81e83a15d83060037461df6d116 /man/pl/Makefile.in
parentafa4f4f104a6ab8dcfb3468dedbe25a2cf715461 (diff)
Fix replace.sed prerequisite syntax
Suffix rules may not have prerequisites. Thanks to Nikola Forró; fixes Fedora bug #1263930. * man/Rules.man: Declare dependency of $(MANS) on replace.sed separately rather than trying to do so in suffix rules. * NEWS: Document this.
Diffstat (limited to 'man/pl/Makefile.in')
-rw-r--r--man/pl/Makefile.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/man/pl/Makefile.in b/man/pl/Makefile.in
index 0c8bd4d3..727fb3e6 100644
--- a/man/pl/Makefile.in
+++ b/man/pl/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@