summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-10-05 11:53:09 +0100
committerColin Watson <cjwatson@debian.org>2010-10-05 11:53:09 +0100
commit1cefffc62403448747971a59fc7b1393fc0715e8 (patch)
treef1032b46eb043535cebc4ffe501a18c002373463 /man
parentc75694e21594ca9f5b9f118f06f5075e58657a0c (diff)
* man/po4a/Makefile.am (clean-local): Don't use 'po4a
--rm-translations', since it sometimes updates PO/POT files and the obvious workaround for that breaks 'make distcheck'. Reimplement it by hand instead.
Diffstat (limited to 'man')
-rw-r--r--man/po4a/Makefile.am11
-rw-r--r--man/po4a/Makefile.in11
2 files changed, 10 insertions, 12 deletions
diff --git a/man/po4a/Makefile.am b/man/po4a/Makefile.am
index 299731d0..11cbe47c 100644
--- a/man/po4a/Makefile.am
+++ b/man/po4a/Makefile.am
@@ -35,13 +35,12 @@ all-local:
update-po:
$(PO4A) $(PO4A_ARGS) --no-translations $(srcdir)/po4a.cfg
+# Ideally we would use:
+# $(PO4A) $(PO4A_ARGS) --rm-translations $(srcdir)/po4a.cfg
+# ... but that also updates PO/POT files (http://bugs.debian.org/599179).
clean-local:
- set -e; for preserve in $(POFILES) po/man-db-manpages.pot; do \
- cp -a "$$preserve" "$$preserve.safe"; \
- done
- $(PO4A) $(PO4A_ARGS) --rm-translations $(srcdir)/po4a.cfg
- set -e; for preserve in $(POFILES) po/man-db-manpages.pot; do \
- mv "$$preserve.safe" "$$preserve"; \
+ set -e; for po in $$(cat $(top_srcdir)/man/LINGUAS.po4a); do \
+ rm -f ../$$po/man*/*.man*; \
done
po/man-db-manpages.pot: update-po
diff --git a/man/po4a/Makefile.in b/man/po4a/Makefile.in
index 05816e45..85f7f5d0 100644
--- a/man/po4a/Makefile.in
+++ b/man/po4a/Makefile.in
@@ -1186,13 +1186,12 @@ uninstall-am:
@PO4A_TRUE@update-po:
@PO4A_TRUE@ $(PO4A) $(PO4A_ARGS) --no-translations $(srcdir)/po4a.cfg
+# Ideally we would use:
+# $(PO4A) $(PO4A_ARGS) --rm-translations $(srcdir)/po4a.cfg
+# ... but that also updates PO/POT files (http://bugs.debian.org/599179).
@PO4A_TRUE@clean-local:
-@PO4A_TRUE@ set -e; for preserve in $(POFILES) po/man-db-manpages.pot; do \
-@PO4A_TRUE@ cp -a "$$preserve" "$$preserve.safe"; \
-@PO4A_TRUE@ done
-@PO4A_TRUE@ $(PO4A) $(PO4A_ARGS) --rm-translations $(srcdir)/po4a.cfg
-@PO4A_TRUE@ set -e; for preserve in $(POFILES) po/man-db-manpages.pot; do \
-@PO4A_TRUE@ mv "$$preserve.safe" "$$preserve"; \
+@PO4A_TRUE@ set -e; for po in $$(cat $(top_srcdir)/man/LINGUAS.po4a); do \
+@PO4A_TRUE@ rm -f ../$$po/man*/*.man*; \
@PO4A_TRUE@ done
@PO4A_TRUE@po/man-db-manpages.pot: update-po