summaryrefslogtreecommitdiff
path: root/manual
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-05-02 12:17:24 +0100
committerColin Watson <cjwatson@debian.org>2019-05-02 12:17:24 +0100
commit56c355e8a29fff0adbb6e72c95a37ba8ccac2e12 (patch)
treea1a31cc2d4699f687345cd469e4b3cbb1f62c8e7 /manual
parent45e00cf967c91c1d95fab736d5587c29ed4ef265 (diff)
Make manual build more robust against failures
Fixes Savannah bug #56254. * manual/Makefile.am ($(MANUAL).pp, .pp.dvi, .pp.ps, .pp.tdvi, .tdvi.tps, .pp.cat, .pp.html): Write output to *.new files and rename into place, so that failures are properly retried in future runs.
Diffstat (limited to 'manual')
-rw-r--r--manual/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/manual/Makefile.am b/manual/Makefile.am
index 6cf339ea..23321811 100644
--- a/manual/Makefile.am
+++ b/manual/Makefile.am
@@ -60,25 +60,25 @@ version: $(top_srcdir)/configure.ac
echo '.ds V $(roff_version)' > $@
$(MANUAL).pp: $(ME_FILES) version
- $(SOELIM) -I$(srcdir) man_db.me | tbl > $@
+ $(SOELIM) -I$(srcdir) man_db.me | tbl > $@.new && mv $@.new $@
.pp.dvi:
- $(TROFF) -me -Tdvi $< > $@
+ $(TROFF) -me -Tdvi $< > $@.new && mv $@.new $@
.pp.ps:
- $(TROFF) -me -Tps $< > $@
+ $(TROFF) -me -Tps $< > $@.new && mv $@.new $@
.pp.tdvi:
- $(TROFF) -me -Tdvi $< | grodvi -d > $@
+ $(TROFF) -me -Tdvi $< | grodvi -d > $@.new && mv $@.new $@
.tdvi.tps:
- dvips -f -t a4 $< > $@
+ dvips -f -t a4 $< > $@.new && mv $@.new $@
.pp.cat:
- LC_ALL=C nroff -me $< > $@
+ LC_ALL=C nroff -me $< > $@.new && mv $@.new $@
.pp.html:
- $(TROFF) -me -Thtml -P-I$* $< > $@
+ $(TROFF) -me -Thtml -P-I$* $< > $@.new && mv $@.new $@
# Automake defines these targets already, so we need to use -local.
dvi-local: $(MANUAL).dvi