summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-09-23 22:07:55 +0100
committerColin Watson <cjwatson@debian.org>2022-09-23 22:07:55 +0100
commit312e096ceb9e41f1d96734a0734934e89e9226ad (patch)
tree87eabeb03b6bd56dafbe17ee6ec792bbef29268c /src/Makefile.am
parent4cbb67968dd3db7f0140ca50489683c892cd5a10 (diff)
Move compression file name utilities to lib/
This makes more sense as a home for plain file name manipulation utilities. I also merged `include/comp_src.h.in` into `lib/compression.c`, because structure definitions (as opposed to declarations) don't belong in header files. * src/compression.c: Move to ... * lib/compression.c: ... here. Remove unnecessary `pipeline.h` include. * src/compression.h: Move to ... * lib/compression.h: ... here. Update positioning of all includes. * lib/Makefile.am (libman_la_SOURCES): Add `compression.c` and `compression.h`. * lib/README: Add `compression.*`. * src/Makefile.am (lexgrog_SOURCES, man_SOURCES, man_recode_SOURCES, mandb_SOURCES): Remove `compression.c` and `compression.h`. * include/comp_src.h (comp_list): Move to ... * lib/compression.c (comp_list): ... here. Update all references. * include/manconfig.h (struct compression, comp_list): Move to ... * lib/compression.h (struct compression, comp_list): ... here. Add includes where necessary. * Makefile.am (noinst_HEADERS): Remove `include/comp_src.h`.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7d4a398b..c92c852b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -84,8 +84,6 @@ globbing_SOURCES = \
globbing.h \
globbing_test.c
lexgrog_SOURCES = \
- compression.c \
- compression.h \
convert.c \
convert.h \
decompress.c \
@@ -108,8 +106,6 @@ lexgrog_SOURCES = \
utf8.c \
utf8.h
man_SOURCES = \
- compression.c \
- compression.h \
decompress.c \
decompress.h \
filenames.c \
@@ -130,8 +126,6 @@ man_SOURCES = \
zsoelim.h \
zsoelim.l
man_recode_SOURCES = \
- compression.c \
- compression.h \
decompress.c \
decompress.h \
man-recode.c \
@@ -150,8 +144,6 @@ manconv_SOURCES = \
mandb_SOURCES = \
check_mandirs.c \
check_mandirs.h \
- compression.c \
- compression.h \
decompress.c \
decompress.h \
descriptions.c \