summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-02-04 15:11:47 +0000
committerColin Watson <cjwatson@debian.org>2022-02-04 15:11:47 +0000
commit828b489c68a5a022c106656cfdff19bb9b584eec (patch)
tree7225919cd6e445d94080fa108a1a6b05fb890cf7 /src/Makefile.am
parenta2d4ffce13a855f29a63bac2099ebe0f5a4e50bd (diff)
parentbfe34108bc20e9d75e3f08bfc8305e4f4cd632a9 (diff)
Import man-db_2.10.0.orig.tar.xz
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c513bad3..e55cdda2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,7 +39,7 @@ noinst_DATA = man_db.conf
EXTRA_DIST = lexgrog.c zsoelim.c
AM_CPPFLAGS = \
- -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
-I$(top_builddir)/gl/lib \
-I$(top_srcdir)/gl/lib \
-I$(top_srcdir)/lib \
@@ -86,6 +86,9 @@ globbing_SOURCES = \
globbing_test.c
lexgrog_SOURCES = \
compression.c \
+ compression.h \
+ convert.c \
+ convert.h \
decompress.c \
decompress.h \
descriptions.c \
@@ -94,6 +97,7 @@ lexgrog_SOURCES = \
filenames.h \
globbing.c \
globbing.h \
+ lexgrog.h \
lexgrog.l \
lexgrog_test.c \
manconv.c \
@@ -101,9 +105,12 @@ lexgrog_SOURCES = \
manconv_client.c \
manconv_client.h \
ult_src.c \
- ult_src.h
+ ult_src.h \
+ utf8.c \
+ utf8.h
man_SOURCES = \
compression.c \
+ compression.h \
decompress.c \
decompress.h \
filenames.c \
@@ -119,17 +126,22 @@ man_SOURCES = \
manp.h \
ult_src.c \
ult_src.h \
+ utf8.c \
+ utf8.h \
zsoelim.h \
zsoelim.l
man_recode_SOURCES = \
compression.c \
+ compression.h \
decompress.c \
decompress.h \
man-recode.c \
manconv.c \
manconv.h \
manconv_client.c \
- manconv_client.h
+ manconv_client.h \
+ utf8.c \
+ utf8.h
manconv_SOURCES = \
decompress.c \
decompress.h \
@@ -140,6 +152,7 @@ mandb_SOURCES = \
check_mandirs.c \
check_mandirs.h \
compression.c \
+ compression.h \
decompress.c \
decompress.h \
descriptions.c \
@@ -149,6 +162,7 @@ mandb_SOURCES = \
filenames.h \
globbing.c \
globbing.h \
+ lexgrog.h \
lexgrog.l \
manconv.c \
manconv.h \
@@ -158,8 +172,11 @@ mandb_SOURCES = \
manp.c \
manp.h \
straycats.c \
+ straycats.h \
ult_src.c \
- ult_src.h
+ ult_src.h \
+ utf8.c \
+ utf8.h
manpath_SOURCES = \
globbing.c \
globbing.h \
@@ -167,6 +184,8 @@ manpath_SOURCES = \
manp.h \
manpath.c
whatis_SOURCES = \
+ convert.c \
+ convert.h \
globbing.c \
globbing.h \
manp.c \