summaryrefslogtreecommitdiff
path: root/src/descriptions_store.c
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2007-02-12 17:47:19 +0000
committerColin Watson <cjwatson@debian.org>2007-02-12 17:47:19 +0000
commit02492dc48374f94eca9cd7374b093d3d723ea7c9 (patch)
tree06133eaac09b9882856263a6619d137dd92b53a0 /src/descriptions_store.c
parent910bb619b7186a904fabe6edcf13b7a18418fa93 (diff)
* lib/debug.c: New file for debugging functions.
* include/manconfig.h.in: debug -> debug_level; prototype debug and debug_error. * lib/Makefile.in (ALL): Add debug.o. * Update all emissions of debugging messages to use the new functions where possible; otherwise, debug -> debug_level.
Diffstat (limited to 'src/descriptions_store.c')
-rw-r--r--src/descriptions_store.c7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/descriptions_store.c b/src/descriptions_store.c
index 4c3ae117..40e20c8d 100644
--- a/src/descriptions_store.c
+++ b/src/descriptions_store.c
@@ -61,8 +61,7 @@ void store_descriptions (const struct page_description *head,
const struct page_description *desc;
char save_id = info->id;
- if (debug)
- fprintf (stderr, "base_name = '%s'\n", base_name);
+ debug ("base_name = '%s'\n", base_name);
for (desc = head; desc; desc = desc->next) {
/* Either it's the real thing or merely a reference. Get the
@@ -84,9 +83,7 @@ void store_descriptions (const struct page_description *head,
info->whatis = NULL;
}
- if (debug)
- fprintf (stderr, "name = '%s', id = %c\n",
- desc->name, info->id);
+ debug ("name = '%s', id = %c\n", desc->name, info->id);
if (dbstore (info, desc->name) > 0) {
gripe_bad_store (base_name, info->ext);
break;