summaryrefslogtreecommitdiff
path: root/src/man.c
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-16 16:45:46 +0000
committerColin Watson <cjwatson@debian.org>2022-01-16 16:45:46 +0000
commit4e3a383c3a7a47533b047c8fde509d990058bbdd (patch)
treec9d848c58e1f2660c89b2d1b09abed6a9ac5d7ca /src/man.c
parent1b32c829e19e4d47776274d9d8b5b59345cb7c56 (diff)
Move util.c-related declarations out of manconfig.h
* include/manconfig.h (is_changed, is_directory, escape_shell, remove_directory, trim_spaces, lang_dir, init_locale): Move to ... * lib/util.h: ... here (new file). * lib/Makefile.am (libman_la_SOURCES): Add util.h. * lib/util.c, src/accessdb.c, src/catman.c, src/check_mandirs.c, src/descriptions.c, src/globbing.c, src/globbing_test.c, src/lexgrog.l, src/lexgrog_test.c, src/man-recode.c, src/man.c, src/manconv_main.c, src/mandb.c, src/manp.c, src/manpath.c, src/straycats.c, src/whatis.c, src/zsoelim_main.c: Include util.h.
Diffstat (limited to 'src/man.c')
-rw-r--r--src/man.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/man.c b/src/man.c
index b45af004..9a80258e 100644
--- a/src/man.c
+++ b/src/man.c
@@ -93,6 +93,7 @@
#include "encodings.h"
#include "orderfiles.h"
#include "sandbox.h"
+#include "util.h"
#include "mydbm.h"
#include "db_storage.h"