summaryrefslogtreecommitdiff
path: root/src/man.c
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-16 17:03:08 +0000
committerColin Watson <cjwatson@debian.org>2022-01-16 17:03:08 +0000
commit8161dece9d0c202668251ca8ad6d89c3bbca566f (patch)
tree14a3d98e2bf37faf3acf96e73eca24cb1c940d5e /src/man.c
parent8f65ff6da2c80a881c81a2eba95ae1025ef501d3 (diff)
Move debug-related declarations out of manconfig.h
* include/manconfig.h (debug_level, init_debug, debug, debug_error): Move to ... * lib/debug.h: ... here (new file). * lib/Makefile.am (libman_la_SOURCES): Add debug.h. * lib/README: Update file names. * lib/debug.c, lib/encodings.c, lib/sandbox.c, lib/security.c, lib/util.c, libdb/db_btree.c, libdb/db_delete.c, libdb/db_gdbm.c, libdb/db_lookup.c, libdb/db_store.c, libdb/db_ver.c, src/accessdb.c, src/catman.c, src/check_mandirs.c, src/descriptions.c, src/descriptions_store.c, src/filenames.c, src/globbing.c, src/globbing_test.c, src/lexgrog_test.c, src/man-recode.c, src/man.c, src/manconv.c, src/manconv_main.c, src/mandb.c, src/manp.c, src/manpath.c, src/straycats.c, src/ult_src.c, src/whatis.c, src/zsoelim.l, src/zsoelim_main.c: Include debug.h.
Diffstat (limited to 'src/man.c')
-rw-r--r--src/man.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/man.c b/src/man.c
index 26819136..8fc04492 100644
--- a/src/man.c
+++ b/src/man.c
@@ -60,6 +60,7 @@
#include "argp.h"
#include "attribute.h"
#include "dirname.h"
+#include "error.h"
#include "gl_array_list.h"
#include "gl_hash_map.h"
#include "gl_list.h"
@@ -81,8 +82,8 @@
#include "manconfig.h"
-#include "error.h"
#include "cleanup.h"
+#include "debug.h"
#include "glcontainers.h"
#include "pipeline.h"
#include "pathsearch.h"