summaryrefslogtreecommitdiff
path: root/src/tests
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-01-23 13:41:16 +0000
committerColin Watson <cjwatson@debian.org>2014-01-23 13:41:16 +0000
commit41796ca9a5295b1c2f6984aada8da7ea2552dbf8 (patch)
tree56e9fd1c229c1683da2b82e8cff8632f082bd5b2 /src/tests
parentf26aa9dc1836ef4fbc6bb0487b30e2be3bb4827f (diff)
Tidy up override directory support slightly
* src/manp.c (insert_override_dir): Drop braces. (get_manpath_from_path): Standardise whitespace. * src/tests/Makefile.am (TESTS_ENVIRONMENT): Use Automake-generated substitution rather than substituting @override_dir@ again.
Diffstat (limited to 'src/tests')
-rw-r--r--src/tests/Makefile.am2
-rw-r--r--src/tests/Makefile.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index df4afc3d..aea38005 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -23,7 +23,7 @@ TESTS_ENVIRONMENT = PATH=..:$$PATH; export PATH; \
MANDIR_LAYOUT=$(MANDIR_LAYOUT); export MANDIR_LAYOUT; \
top_builddir=$(top_builddir); export top_builddir; \
@LOCALCHARSET_TESTS_ENVIRONMENT@; export CHARSETALIASDIR; \
- OVERRIDE_DIR="@override_dir@"; export OVERRIDE_DIR;
+ OVERRIDE_DIR="$(override_dir)"; export OVERRIDE_DIR;
# Each test must use the configure-detected shell, not necessarily /bin/sh.
AM_LOG_FLAGS = $(SHELL)
ALL_TESTS = \
diff --git a/src/tests/Makefile.in b/src/tests/Makefile.in
index ecaeebe6..471f8ed8 100644
--- a/src/tests/Makefile.in
+++ b/src/tests/Makefile.in
@@ -1431,7 +1431,7 @@ TESTS_ENVIRONMENT = PATH=..:$$PATH; export PATH; \
MANDIR_LAYOUT=$(MANDIR_LAYOUT); export MANDIR_LAYOUT; \
top_builddir=$(top_builddir); export top_builddir; \
@LOCALCHARSET_TESTS_ENVIRONMENT@; export CHARSETALIASDIR; \
- OVERRIDE_DIR="@override_dir@"; export OVERRIDE_DIR;
+ OVERRIDE_DIR="$(override_dir)"; export OVERRIDE_DIR;
# Each test must use the configure-detected shell, not necessarily /bin/sh.
AM_LOG_FLAGS = $(SHELL)