summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am5
-rw-r--r--Makefile.in6
2 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d30c8b68..e591ba89 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,11 @@ EXTRA_DIST += \
gnulib/m4/uintmax_t.m4 \
gnulib/m4/visibility.m4
+# The default for systemdtmpfilesdir is intentionally not prefix-sensitive,
+# but we need to adjust it in order for distcheck to pass.
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --with-systemdtmpfilesdir=\$${prefix}/lib/tmpfiles.d
+
# We deliberately leave the configuration file in place on uninstall, since
# it may contain local customisations.
distuninstallcheck_listfiles = \
diff --git a/Makefile.in b/Makefile.in
index ee65c4f0..e66c2459 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1397,6 +1397,12 @@ EXTRA_DIST = .gitignore ChangeLog-2013 autogen.sh \
gnulib/m4/printf-posix.m4 gnulib/m4/uintmax_t.m4 \
gnulib/m4/visibility.m4
+# The default for systemdtmpfilesdir is intentionally not prefix-sensitive,
+# but we need to adjust it in order for distcheck to pass.
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --with-systemdtmpfilesdir=\$${prefix}/lib/tmpfiles.d
+
+
# We deliberately leave the configuration file in place on uninstall, since
# it may contain local customisations.
distuninstallcheck_listfiles = \