summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am3
-rw-r--r--Makefile.in3
2 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a64d12..ba87b7b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,9 +53,12 @@ EXTRA_DIST += \
gnulib/m4/uintmax_t.m4 \
gnulib/m4/visibility.m4
+# Installing in --enable-setuid mode (the default) requires root; disable
+# this so that distcheck can be run as non-root.
# The default for systemdtmpfilesdir is intentionally not prefix-sensitive,
# but we need to adjust it in order for distcheck to pass.
AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-setuid \
--with-systemdtmpfilesdir=\$${prefix}/lib/tmpfiles.d
# We deliberately leave the configuration file in place on uninstall, since
diff --git a/Makefile.in b/Makefile.in
index 5349805d..69c99cef 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1428,9 +1428,12 @@ EXTRA_DIST = .gitignore ChangeLog-2013 autogen.sh \
gnulib/m4/printf-posix.m4 gnulib/m4/sockpfaf.m4 \
gnulib/m4/uintmax_t.m4 gnulib/m4/visibility.m4
+# Installing in --enable-setuid mode (the default) requires root; disable
+# this so that distcheck can be run as non-root.
# The default for systemdtmpfilesdir is intentionally not prefix-sensitive,
# but we need to adjust it in order for distcheck to pass.
AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-setuid \
--with-systemdtmpfilesdir=\$${prefix}/lib/tmpfiles.d