summaryrefslogtreecommitdiff
path: root/gl/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gl/lib/Makefile.am')
-rw-r--r--gl/lib/Makefile.am66
1 files changed, 60 insertions, 6 deletions
diff --git a/gl/lib/Makefile.am b/gl/lib/Makefile.am
index 8e04cbbb..a8e268e2 100644
--- a/gl/lib/Makefile.am
+++ b/gl/lib/Makefile.am
@@ -81,14 +81,17 @@
# setenv \
# sigaction \
# signal-h \
+# sigpipe \
# sigprocmask \
# stat-time \
# stdbool \
+# stpcpy \
# strcase \
# strcasestr \
# strerror \
# strsep \
# tempname \
+# termios \
# timespec \
# unlinkat \
# utimens \
@@ -1601,6 +1604,18 @@ endif
## end gnulib module readlink
+## begin gnulib module readlinkat
+
+if GL_COND_OBJ_READLINKAT
+libgnu_la_SOURCES += readlinkat.c
+endif
+
+EXTRA_DIST += at-func.c
+
+EXTRA_libgnu_la_SOURCES += at-func.c
+
+## end gnulib module readlinkat
+
## begin gnulib module realloc-gnu
@@ -1807,6 +1822,15 @@ EXTRA_DIST += signal.in.h
## end gnulib module signal-h
+## begin gnulib module sigpipe
+
+
+EXTRA_DIST += stdio-write.c
+
+EXTRA_libgnu_la_SOURCES += stdio-write.c
+
+## end gnulib module sigpipe
+
## begin gnulib module sigprocmask
if GL_COND_OBJ_SIGPROCMASK
@@ -1905,12 +1929,6 @@ EXTRA_DIST += stat-time.h
## end gnulib module stat-time
-## begin gnulib module statat
-
-libgnu_la_SOURCES += statat.c
-
-## end gnulib module statat
-
## begin gnulib module stdalign
BUILT_SOURCES += $(STDALIGN_H)
@@ -2356,6 +2374,14 @@ EXTRA_DIST += stdopen.h
## end gnulib module stdopen
+## begin gnulib module stpcpy
+
+if GL_COND_OBJ_STPCPY
+libgnu_la_SOURCES += stpcpy.c
+endif
+
+## end gnulib module stpcpy
+
## begin gnulib module strcase
if GL_COND_OBJ_STRCASECMP
@@ -2783,6 +2809,7 @@ sys/stat.h: sys_stat.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNU
-e 's|@''NEXT_SYS_STAT_H''@|$(NEXT_SYS_STAT_H)|g' \
-e 's|@''WINDOWS_64_BIT_ST_SIZE''@|$(WINDOWS_64_BIT_ST_SIZE)|g' \
-e 's|@''WINDOWS_STAT_TIMESPEC''@|$(WINDOWS_STAT_TIMESPEC)|g' \
+ -e 's/@''GNULIB_CHMOD''@/$(GL_GNULIB_CHMOD)/g' \
-e 's/@''GNULIB_FCHMODAT''@/$(GL_GNULIB_FCHMODAT)/g' \
-e 's/@''GNULIB_FSTAT''@/$(GL_GNULIB_FSTAT)/g' \
-e 's/@''GNULIB_FSTATAT''@/$(GL_GNULIB_FSTATAT)/g' \
@@ -2814,6 +2841,7 @@ sys/stat.h: sys_stat.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNU
-e 's|@''HAVE_MKNOD''@|$(HAVE_MKNOD)|g' \
-e 's|@''HAVE_MKNODAT''@|$(HAVE_MKNODAT)|g' \
-e 's|@''HAVE_UTIMENSAT''@|$(HAVE_UTIMENSAT)|g' \
+ -e 's|@''REPLACE_CHMOD''@|$(REPLACE_CHMOD)|g' \
-e 's|@''REPLACE_FCHMODAT''@|$(REPLACE_FCHMODAT)|g' \
-e 's|@''REPLACE_FSTAT''@|$(REPLACE_FSTAT)|g' \
-e 's|@''REPLACE_FSTATAT''@|$(REPLACE_FSTATAT)|g' \
@@ -2953,6 +2981,32 @@ EXTRA_DIST += tempname.h
## end gnulib module tempname
+## begin gnulib module termios
+
+BUILT_SOURCES += termios.h
+
+# We need the following in order to create <termios.h> when the system
+# version does not have all declarations.
+termios.h: termios.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(WARN_ON_USE_H)
+ $(gl_V_at)$(SED_HEADER_STDOUT) \
+ -e 's|@''GUARD_PREFIX''@|GL|g' \
+ -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
+ -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
+ -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
+ -e 's|@''NEXT_TERMIOS_H''@|$(NEXT_TERMIOS_H)|g' \
+ -e 's/@''GNULIB_TCGETSID''@/$(GL_GNULIB_TCGETSID)/g' \
+ -e 's|@''HAVE_DECL_TCGETSID''@|$(HAVE_DECL_TCGETSID)|g' \
+ -e 's|@''HAVE_TERMIOS_H''@|$(HAVE_TERMIOS_H)|g' \
+ -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \
+ -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)' \
+ $(srcdir)/termios.in.h > $@-t
+ $(AM_V_at)mv $@-t $@
+MOSTLYCLEANFILES += termios.h termios.h-t
+
+EXTRA_DIST += termios.in.h
+
+## end gnulib module termios
+
## begin gnulib module threadlib
libgnu_la_SOURCES += glthread/threadlib.c