summaryrefslogtreecommitdiff
path: root/gnulib/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gnulib/lib/Makefile.am')
-rw-r--r--gnulib/lib/Makefile.am24
1 files changed, 22 insertions, 2 deletions
diff --git a/gnulib/lib/Makefile.am b/gnulib/lib/Makefile.am
index 40c6a5fd..a6878828 100644
--- a/gnulib/lib/Makefile.am
+++ b/gnulib/lib/Makefile.am
@@ -174,7 +174,7 @@ EXTRA_DIST += close-hook.h
# The Automake-defined pkg* macros are appended, in the order
# listed in the Automake 1.10a+ documentation.
configmake.h: Makefile
- rm -f $@-t $@
+ rm -f $@-t
{ echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
echo '#define PREFIX "$(prefix)"'; \
echo '#define EXEC_PREFIX "$(exec_prefix)"'; \
@@ -204,7 +204,12 @@ configmake.h: Makefile
echo '#define PKGLIBDIR "$(pkglibdir)"'; \
echo '#define PKGLIBEXECDIR "$(pkglibexecdir)"'; \
} | sed '/""/d' > $@-t
- mv $@-t $@
+ if test -f $@ && cmp $@-t $@ > /dev/null; then \
+ rm -f $@-t; \
+ else \
+ rm -f $@; mv $@-t $@; \
+ fi
+
BUILT_SOURCES += configmake.h
CLEANFILES += configmake.h configmake.h-t
@@ -691,6 +696,15 @@ EXTRA_libgnu_a_SOURCES += mbsinit.c
## end gnulib module mbsinit
+## begin gnulib module mbsrtowcs
+
+
+EXTRA_DIST += mbsrtowcs-state.c mbsrtowcs.c
+
+EXTRA_libgnu_a_SOURCES += mbsrtowcs-state.c mbsrtowcs.c
+
+## end gnulib module mbsrtowcs
+
## begin gnulib module memcmp
@@ -1309,6 +1323,12 @@ EXTRA_libgnu_a_SOURCES += strnlen.c
## end gnulib module strnlen
+## begin gnulib module strnlen1
+
+libgnu_a_SOURCES += strnlen1.h strnlen1.c
+
+## end gnulib module strnlen1
+
## begin gnulib module strsep