summaryrefslogtreecommitdiff
path: root/init/systemd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'init/systemd/Makefile.am')
-rw-r--r--init/systemd/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/init/systemd/Makefile.am b/init/systemd/Makefile.am
index a79caf10..67397b58 100644
--- a/init/systemd/Makefile.am
+++ b/init/systemd/Makefile.am
@@ -18,11 +18,21 @@
## along with man-db; if not, write to the Free Software Foundation,
## Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-EXTRA_DIST = man-db.conf.in
+EXTRA_DIST = \
+ man-db.conf.in \
+ man-db.service.in
-CLEANFILES = man-db.conf
+CLEANFILES = \
+ man-db.conf \
+ man-db.service
nodist_systemdtmpfiles_DATA = man-db.conf
+systemdsystemunit_DATA = man-db.timer
+nodist_systemdsystemunit_DATA = man-db.service
+
man-db.conf: man-db.conf.in
sed -e "s,[@]cache_top_owner[@],$(cache_top_owner),g" $< > $@
+
+man-db.service: man-db.service.in
+ sed -e "s,[@]bindir[@],$(bindir),g" $< > $@