summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 5 insertions, 19 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7d4a398b..fbeccf4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -64,7 +64,7 @@ catman_LDADD = $(LIBMANDB) $(libpipeline_LIBS)
globbing_LDADD = $(LIBMAN)
lexgrog_LDADD = $(LIBMAN) $(LIBCOMPRESS) $(libpipeline_LIBS) $(LTLIBICONV)
man_LDADD = $(LIBMANDB) $(LIBCOMPRESS) $(libpipeline_LIBS) $(LTLIBICONV)
-man_recode_LDADD = $(LIBMANDB) $(LIBCOMPRESS) $(libpipeline_LIBS) $(LTLIBICONV)
+man_recode_LDADD = $(LIBMAN) $(LIBCOMPRESS) $(libpipeline_LIBS) $(LTLIBICONV)
manconv_LDADD = $(LIBMAN) $(LIBCOMPRESS) $(libpipeline_LIBS) $(LTLIBICONV)
mandb_LDADD = $(LIBMANDB) $(LIBCOMPRESS) $(libpipeline_LIBS) $(LTLIBICONV)
manpath_LDADD = $(LIBMAN)
@@ -84,16 +84,12 @@ globbing_SOURCES = \
globbing.h \
globbing_test.c
lexgrog_SOURCES = \
- compression.c \
- compression.h \
convert.c \
convert.h \
decompress.c \
decompress.h \
descriptions.c \
descriptions.h \
- filenames.c \
- filenames.h \
globbing.c \
globbing.h \
lexgrog.h \
@@ -108,12 +104,8 @@ lexgrog_SOURCES = \
utf8.c \
utf8.h
man_SOURCES = \
- compression.c \
- compression.h \
decompress.c \
decompress.h \
- filenames.c \
- filenames.h \
globbing.c \
globbing.h \
man.c \
@@ -130,8 +122,6 @@ man_SOURCES = \
zsoelim.h \
zsoelim.l
man_recode_SOURCES = \
- compression.c \
- compression.h \
decompress.c \
decompress.h \
man-recode.c \
@@ -150,15 +140,11 @@ manconv_SOURCES = \
mandb_SOURCES = \
check_mandirs.c \
check_mandirs.h \
- compression.c \
- compression.h \
decompress.c \
decompress.h \
descriptions.c \
descriptions.h \
descriptions_store.c \
- filenames.c \
- filenames.h \
globbing.c \
globbing.h \
lexgrog.h \
@@ -212,12 +198,12 @@ all-am: apropos$(EXEEXT)
install-exec-hook:
if [ "$(man_owner)" ] && [ "$(man_mode)" = 6755 ]; then \
chown $(man_owner):$(man_owner) \
- $(DESTDIR)$(bindir)/$(TRANS_MAN) \
- $(DESTDIR)$(bindir)/$(TRANS_MANDB); \
+ $(DESTDIR)$(bindir)/$(TRANS_MAN)$(EXEEXT) \
+ $(DESTDIR)$(bindir)/$(TRANS_MANDB)$(EXEEXT); \
fi
chmod $(man_mode) \
- $(DESTDIR)$(bindir)/$(TRANS_MAN) \
- $(DESTDIR)$(bindir)/$(TRANS_MANDB)
+ $(DESTDIR)$(bindir)/$(TRANS_MAN)$(EXEEXT) \
+ $(DESTDIR)$(bindir)/$(TRANS_MANDB)$(EXEEXT)
cd $(DESTDIR)$(bindir) && rm -f $(TRANS_APROPOS)$(EXEEXT) && \
$(LN_S) $(TRANS_WHATIS)$(EXEEXT) $(TRANS_APROPOS)$(EXEEXT)