summaryrefslogtreecommitdiff
path: root/.gitignore
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2022-09-23 21:47:20 +0200
committerAndrej Shadura <andrewsh@debian.org>2022-09-23 21:47:20 +0200
commita69ab6b76a6e6677a1113f949af17015d13d756c (patch)
tree5a5fb46d5efec7aef0c5d0ec59c52607515ed22c /.gitignore
parenta8a30d403f4d72f1dfbc16620a94bc6051b110c4 (diff)
New upstream version 1.68.0~rc2
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore10
1 files changed, 9 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index e58affb2..15fbfddd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -15,8 +15,9 @@ _trial_temp*/
.DS_Store
__pycache__/
-# We do want the poetry lockfile.
+# We do want the poetry and cargo lockfile.
!poetry.lock
+!Cargo.lock
# stuff that is likely to exist when you run a server locally
/*.db
@@ -60,3 +61,10 @@ book/
# complement
/complement-*
/master.tar.gz
+
+# rust
+/target/
+/synapse/*.so
+
+# Poetry will create a setup.py, which we don't want to include.
+/setup.py