summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2018-09-12 15:03:47 +0200
committerAndrej Shadura <andrewsh@debian.org>2018-09-12 15:06:08 +0200
commit571d3657b97e6e891dc0303ff49ed592bb02c87e (patch)
treef58fa7f2749d6f0d27554bc1e2675dbf61010217
parentf05d4bc8c767b644c40f692a85327d8e38c08bfc (diff)
parentc55f00b24b052553705b9d551cecc9278878cbad (diff)
Merge remote-tracking branch 'matrix/debian' into debian/master
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/no_install_with_pip37
-rw-r--r--debian/patches/remove-webclient.patch29
-rw-r--r--debian/patches/series1
4 files changed, 46 insertions, 29 deletions
diff --git a/debian/changelog b/debian/changelog
index c3d2c3ae..e0fc2ee6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+matrix-synapse (0.33.4-1) UNRELEASED; urgency=medium
+
+ * New upstream version.
+ * Avoid telling people to install packages with pip
+ (fixes https://github.com/matrix-org/synapse/issues/3743)
+
+ -- Richard van der Hoff <richard@matrix.org> Fri, 07 Sep 2018 14:06:17 +0100
+
matrix-synapse (0.33.3-2) unstable; urgency=medium
[ Richard van der Hoff ]
diff --git a/debian/patches/no_install_with_pip b/debian/patches/no_install_with_pip
new file mode 100644
index 00000000..c7976cf0
--- /dev/null
+++ b/debian/patches/no_install_with_pip
@@ -0,0 +1,37 @@
+--- a/synapse/app/__init__.py
++++ b/synapse/app/__init__.py
+@@ -25,8 +25,8 @@
+ except python_dependencies.MissingRequirementError as e:
+ message = "\n".join([
+ "Missing Requirement: %s" % (e.message,),
+- "To install run:",
+- " pip install --upgrade --force \"%s\"" % (e.dependency,),
++ "To install, try:",
++ " sudo apt-get install python-%s" % (e.dependency,),
+ "",
+ ])
+ sys.stderr.writelines(message)
+--- a/synapse/config/jwt.py
++++ b/synapse/config/jwt.py
+@@ -19,7 +19,7 @@
+ """Missing jwt library. This is required for jwt login.
+
+ Install by running:
+- pip install pyjwt
++ sudo apt-get install python-jwt
+ """
+ )
+
+--- a/synapse/config/repository.py
++++ b/synapse/config/repository.py
+@@ -27,9 +27,7 @@
+ """Missing lxml library. This is required for URL preview API.
+
+ Install by running:
+- pip install lxml
+-
+- Requires libxslt1-dev system package.
++ sudo apt-get install python-lxml
+ """
+ )
+
diff --git a/debian/patches/remove-webclient.patch b/debian/patches/remove-webclient.patch
deleted file mode 100644
index 07a55489..00000000
--- a/debian/patches/remove-webclient.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/synapse/app/homeserver.py
-+++ b/synapse/app/homeserver.py
-@@ -118,7 +118,7 @@ class SynapseHomeServer(HomeServer):
- for res in listener_config["resources"]:
- for name in res["names"]:
- resources.update(self._configure_named_resource(
-- name, res.get("compress", False),
-+ config, name, res.get("compress", False),
- ))
-
- additional_resources = listener_config.get("additional_resources", {})
-@@ -165,7 +165,7 @@ class SynapseHomeServer(HomeServer):
- )
- logger.info("Synapse now listening on port %d", port)
-
-- def _configure_named_resource(self, name, compress=False):
-+ def _configure_named_resource(self, config, name, compress=False):
- """Build a resource map for a named resource
-
- Args:
-@@ -232,7 +232,7 @@ class SynapseHomeServer(HomeServer):
- SERVER_KEY_V2_PREFIX: KeyApiV2Resource(self),
- })
-
-- if name == "webclient":
-+ if name == "webclient" and config.web_client:
- resources[WEB_CLIENT_PREFIX] = build_resource_for_web_client(self)
-
- if name == "metrics" and self.get_config().enable_metrics:
diff --git a/debian/patches/series b/debian/patches/series
index 04d1a652..6400d5dc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
0002-change_instructions.patch
0004-webclient-instructions.patch
0005-Honour-config.web_client.patch
+no_install_with_pip