summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard van der Hoff <richard@matrix.org>2018-08-09 15:36:11 +0100
committerRichard van der Hoff <richard@matrix.org>2018-08-09 15:36:11 +0100
commitf18a5611ecabc915919b5c948e6ef4e289ad3b26 (patch)
tree9e419b6cbf0294a11a159cc4decb45e3cb5a3548
parentde15072877ce5a1254756455523f537e77699fee (diff)
Prepare for 0.33.2 release
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/bcrypt.patch14
2 files changed, 15 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index cea4ac95..3ce6ecc7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+matrix-synapse (0.33.2-1~1.gbpde1507) UNRELEASED; urgency=medium
+
+ ** SNAPSHOT build @de15072877ce5a1254756455523f537e77699fee **
+
+ * UNRELEASED
+
+ -- Richard van der Hoff <richard@matrix.org> Thu, 09 Aug 2018 11:34:14 +0100
+
matrix-synapse (0.33.1-1) jessie; urgency=medium
* New upstream version 0.33.1
diff --git a/debian/patches/bcrypt.patch b/debian/patches/bcrypt.patch
index 74737bce..0ff2c2ef 100644
--- a/debian/patches/bcrypt.patch
+++ b/debian/patches/bcrypt.patch
@@ -2,16 +2,16 @@ Index: package-synapse-debian/synapse/handlers/auth.py
===================================================================
--- package-synapse-debian.orig/synapse/handlers/auth.py
+++ package-synapse-debian/synapse/handlers/auth.py
-@@ -876,10 +876,8 @@ class AuthHandler(BaseHandler):
- """
+@@ -891,10 +891,10 @@ class AuthHandler(BaseHandler):
+ # Normalise the Unicode in the password
+ pw = unicodedata.normalize("NFKC", password)
- def _do_validate_hash():
- return bcrypt.checkpw(
-- password.encode('utf8') + self.hs.config.password_pepper,
-- stored_hash.encode('utf8')
++ return bcrypt.hashpw(
+ pw.encode('utf8') + self.hs.config.password_pepper.encode("utf8"),
+ stored_hash.encode('utf8')
- )
-+ return bcrypt.hashpw(password.encode('utf8') + self.hs.config.password_pepper,
-+ stored_hash.encode('utf8')) == stored_hash
++ ) == stored_hash
if stored_hash:
return make_deferred_yieldable(