summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2022-05-17 11:33:43 +0200
committerAndrej Shadura <andrewsh@debian.org>2022-05-17 11:33:43 +0200
commit59bdc1ed67b5ef55436af95ddbe3810429dfb518 (patch)
treec227bead465278e49fc8c2d6cf256327b5400ecc /debian
parent1b9b92888056ce7fd1f3a010ca7afd5c3963d44e (diff)
New upstream version 1.59.0
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build_virtualenv24
-rw-r--r--debian/changelog48
-rw-r--r--debian/clean1
3 files changed, 69 insertions, 4 deletions
diff --git a/debian/build_virtualenv b/debian/build_virtualenv
index e6911636..f1ec6091 100755
--- a/debian/build_virtualenv
+++ b/debian/build_virtualenv
@@ -30,9 +30,23 @@ case $(dpkg-architecture -q DEB_HOST_ARCH) in
;;
esac
-# Use --builtin-venv to use the better `venv` module from CPython 3.4+ rather
-# than the 2/3 compatible `virtualenv`.
-
+# Manually install Poetry and export a pip-compatible `requirements.txt`
+# We need a Poetry pre-release as the export command is buggy in < 1.2
+TEMP_VENV="$(mktemp -d)"
+python3 -m venv "$TEMP_VENV"
+source "$TEMP_VENV/bin/activate"
+pip install -U pip
+pip install poetry==1.2.0b1
+poetry export \
+ --extras all \
+ --extras test \
+ --extras systemd \
+ -o exported_requirements.txt
+deactivate
+rm -rf "$TEMP_VENV"
+
+# Use --no-deps to only install pinned versions in exported_requirements.txt,
+# and to avoid https://github.com/pypa/pip/issues/9644
dh_virtualenv \
--install-suffix "matrix-synapse" \
--builtin-venv \
@@ -41,9 +55,11 @@ dh_virtualenv \
--preinstall="lxml" \
--preinstall="mock" \
--preinstall="wheel" \
+ --extra-pip-arg="--no-deps" \
--extra-pip-arg="--no-cache-dir" \
--extra-pip-arg="--compile" \
- --extras="all,systemd,test"
+ --extras="all,systemd,test" \
+ --requirements="exported_requirements.txt"
PACKAGE_BUILD_DIR="debian/matrix-synapse-py3"
VIRTUALENV_DIR="${PACKAGE_BUILD_DIR}${DH_VIRTUALENV_INSTALL_ROOT}/matrix-synapse"
diff --git a/debian/changelog b/debian/changelog
index 2db6ed94..cc6152d5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,51 @@
+matrix-synapse-py3 (1.59.0) stable; urgency=medium
+
+ * New Synapse release 1.59.0.
+
+ -- Synapse Packaging team <packages@matrix.org> Tue, 17 May 2022 10:26:50 +0100
+
+matrix-synapse-py3 (1.59.0~rc2) stable; urgency=medium
+
+ * New Synapse release 1.59.0rc2.
+
+ -- Synapse Packaging team <packages@matrix.org> Mon, 16 May 2022 12:52:15 +0100
+
+matrix-synapse-py3 (1.59.0~rc1) stable; urgency=medium
+
+ * Adjust how the `exported-requirements.txt` file is generated as part of
+ the process of building these packages. This affects the package
+ maintainers only; end-users are unaffected.
+ * New Synapse release 1.59.0rc1.
+
+ -- Synapse Packaging team <packages@matrix.org> Tue, 10 May 2022 10:45:08 +0100
+
+matrix-synapse-py3 (1.58.1) stable; urgency=medium
+
+ * Include python dependencies from the `systemd` and `cache_memory` extras package groups, which
+ were incorrectly omitted from the 1.58.0 package.
+ * New Synapse release 1.58.1.
+
+ -- Synapse Packaging team <packages@matrix.org> Thu, 05 May 2022 14:58:23 +0100
+
+matrix-synapse-py3 (1.58.0) stable; urgency=medium
+
+ * New Synapse release 1.58.0.
+
+ -- Synapse Packaging team <packages@matrix.org> Tue, 03 May 2022 10:52:58 +0100
+
+matrix-synapse-py3 (1.58.0~rc2) stable; urgency=medium
+
+ * New Synapse release 1.58.0rc2.
+
+ -- Synapse Packaging team <packages@matrix.org> Tue, 26 Apr 2022 17:14:56 +0100
+
+matrix-synapse-py3 (1.58.0~rc1) stable; urgency=medium
+
+ * Use poetry to manage the bundled virtualenv included with this package.
+ * New Synapse release 1.58.0rc1.
+
+ -- Synapse Packaging team <packages@matrix.org> Tue, 26 Apr 2022 11:15:20 +0100
+
matrix-synapse-py3 (1.57.1) stable; urgency=medium
* New synapse release 1.57.1.
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 00000000..d488f298
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+exported_requirements.txt