summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/log.yaml14
-rw-r--r--debian/matrix-synapse.logrotate8
3 files changed, 25 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 3ae4727d..0dfdb8dc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+matrix-synapse (0.99.2-4) unstable; urgency=medium
+
+ [ Antoine Beaupré ]
+ * Fix log rotation to be less verbose (Closes: #927057).
+
+ -- Andrej Shadura <andrewsh@debian.org> Sat, 27 Apr 2019 20:03:23 +0200
+
matrix-synapse (0.99.2-3) unstable; urgency=medium
* Make the code querying the location of the key file actually work.
diff --git a/debian/log.yaml b/debian/log.yaml
index caa3facb..187bc7c4 100644
--- a/debian/log.yaml
+++ b/debian/log.yaml
@@ -14,12 +14,12 @@ filters:
handlers:
file:
- class: logging.handlers.RotatingFileHandler
+ class: logging.handlers.WatchedFileHandler
formatter: precise
filename: /var/log/matrix-synapse/homeserver.log
- maxBytes: 104857600
- backupCount: 10
filters: [context]
+ level: DEBUG
+ encoding: utf8
console:
class: logging.StreamHandler
formatter: precise
@@ -31,12 +31,18 @@ handlers:
SYSLOG_IDENTIFIER: synapse
loggers:
+ twisted:
+ level: WARN
+
synapse:
- level: INFO
+ level: WARN
synapse.storage.SQL:
level: INFO
+ synapse.http.matrixfederationclient:
+ level: ERROR
+
root:
level: INFO
handlers: [file, journal]
diff --git a/debian/matrix-synapse.logrotate b/debian/matrix-synapse.logrotate
new file mode 100644
index 00000000..893e0ee3
--- /dev/null
+++ b/debian/matrix-synapse.logrotate
@@ -0,0 +1,8 @@
+/var/log/matrix-synapse/homeserver.log {
+ rotate 7
+ daily
+ missingok
+ notifempty
+ delaycompress
+ compress
+}