summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorMarkku-Juhani O. Saarinen <mjos@mjos.fi>2017-12-01 14:26:40 +0000
committerManuel Pégourié-Gonnard <manuel.pegourie-gonnard@arm.com>2018-02-27 12:39:12 +0100
commit8df81e029f0f1be2dda67b97ed56739d3a1a34d7 (patch)
treed1a6d33ecc9e63968def5902f36d0e3281a4b7a9 /tests/Makefile
parent6ba68d4a3b421a6b6a2f38a72a7a00ff3ebd598d (diff)
Test suite for ARIA
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 4787f250..1e9b8aa4 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -50,6 +50,7 @@ APPS = test_suite_aes.ecb$(EXEXT) test_suite_aes.cbc$(EXEXT) \
test_suite_arc4$(EXEXT) test_suite_asn1write$(EXEXT) \
test_suite_base64$(EXEXT) test_suite_blowfish$(EXEXT) \
test_suite_camellia$(EXEXT) test_suite_ccm$(EXEXT) \
+ test_suite_aria$(EXEXT) \
test_suite_cmac$(EXEXT) \
test_suite_cipher.aes$(EXEXT) \
test_suite_cipher.arc4$(EXEXT) test_suite_cipher.ccm$(EXEXT) \
@@ -437,6 +438,10 @@ test_suite_version$(EXEXT): test_suite_version.c $(DEP)
echo " CC $<"
$(CC) $(LOCAL_CFLAGS) $(CFLAGS) $< $(LOCAL_LDFLAGS) $(LDFLAGS) -o $@
+test_suite_aria$(EXEXT): test_suite_aria.c $(DEP)
+ echo " CC $<"
+ $(CC) $(LOCAL_CFLAGS) $(CFLAGS) $< $(LOCAL_LDFLAGS) $(LDFLAGS) -o $@
+
clean:
ifndef WINDOWS
rm -f $(APPS) *.c