summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorPaul Bakker <p.j.bakker@polarssl.org>2013-01-16 17:00:05 +0100
committerPaul Bakker <p.j.bakker@polarssl.org>2013-01-16 17:00:05 +0100
commita95919b4c78ced3b494d6028cfed6799b034d743 (patch)
treeaf6fa5d6641ac409226126ca67fe32bf9c476f16 /tests/Makefile
parent5e402d88ea0b2d8d2878d40aaa6c10c8cf95bb88 (diff)
Added ECP files to Makefiles as well
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 4c97aa5d..be5e0983 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -30,6 +30,7 @@ APPS = test_suite_aes test_suite_arc4 \
test_suite_cipher.des test_suite_cipher.null \
test_suite_ctr_drbg test_suite_debug \
test_suite_des test_suite_dhm \
+ test_suite_ecp \
test_suite_error test_suite_gcm.decrypt \
test_suite_gcm.decrypt test_suite_hmac_shax \
test_suite_md test_suite_mdx \
@@ -127,6 +128,10 @@ test_suite_dhm: test_suite_dhm.c ../library/libpolarssl.a
echo " CC $@.c"
$(CC) $(CFLAGS) $(OFLAGS) $@.c $(LDFLAGS) -o $@
+test_suite_ecp: test_suite_ecp.c ../library/libpolarssl.a
+ echo " CC $@.c"
+ $(CC) $(CFLAGS) $(OFLAGS) $@.c $(LDFLAGS) -o $@
+
test_suite_error: test_suite_error.c ../library/libpolarssl.a
echo " CC $@.c"
$(CC) $(CFLAGS) $(OFLAGS) $@.c $(LDFLAGS) -o $@